[Chimera-users] On installation of Chimera linux version

Smith Lee smith_lee123 at yahoo.com
Mon Aug 24 20:32:43 PDT 2020

 Dear All,
With the request from Greg, the result is as following.
$ ldd _tkinter.so
    linux-vdso.so.1 (0x00007ffcd61fa000)
    libtk8.6.so => not found
    libtcl8.6.so => /lib64/libtcl8.6.so (0x00007fe164edd000)
    libX11.so.6 => /lib64/libX11.so.6 (0x00007fe164b99000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe164979000)
    libc.so.6 => /lib64/libc.so.6 (0x00007fe1645b7000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00007fe1643b3000)
    libz.so.1 => /lib64/libz.so.1 (0x00007fe16419c000)
    libm.so.6 => /lib64/libm.so.6 (0x00007fe163e1a000)
    libxcb.so.1 => /lib64/libxcb.so.1 (0x00007fe163bf1000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fe1654af000)
    libXau.so.6 => /lib64/libXau.so.6 (0x00007fe1639ed000)
The version of Chimera involved is: chimera-1.14-linux_x86_64.bin
I am looking forward to getting your advice on how to solve the issue, and if libtk8.6.so is what was missing, how to install it especially in the directory  /UCSF-chimera64-1.14/lib/python2.7/lib-dynload/.


    On Tuesday, August 25, 2020, 8:48:29 AM GMT+8, Greg Couch <gregc at cgl.ucsf.edu> wrote:  
The CHIMERA/bin directory should not be on your path, nor should you run chimera when in the CHIMERA/bin directory.  As part of the installation process it asks  you where you want to put a symbolic link to the chimera binary on your PATH, e.g., if /usr/local/bin is on your PATH, then one of the choices will be /usr/local/bin/chimera.  If you didn't do that, then you need to use the full path to the chimera binary.   So go back to your home directory or a directory with the data you are working on, and run chimera from there.  You can make a symbolic link to the chimera binary anytime to make running it easier.
If that still doesn't work, then I would suspect that there is shared library that is missing.  Run:
    ldd /UCSF-chimera64-1.14/lib/python2.7/lib-dynload/_tkinter.so
And look for missing libraries.  Then use your Linux distribution's package manager to install it.  And please let everyone know which libraries are missing.  And also please share which version of Linux you are using.  With that information, we should be able to figure out which system packages are missing.
 On 8/24/2020 5:07 AM, Smith Lee wrote:
  Dear All, 
>From https://www.cgl.ucsf.edu/chimera/download.html I have downloaded the chimera-1.14-linux_x86_64.bin, and have tried to install it exactly based on the accompanied exact "Instructions”. After the installation completed, I got to the bin folder, and try to launch chimera with ./chimera. However her俄 it says the installed /UCSF-chimera64-1.14/lib/python2.7/lib-tk/Tkinter.py was not configured for my python. 
Will you please let me know how to configure TK for my python, which was a downloaded component of the chimera package? 
Best wishes, 
Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
Manage subscription: https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20200825/dccb6443/attachment.html>

More information about the Chimera-users mailing list