[Chimera-users] On installation of Chimera linux version

Greg Couch gregc at cgl.ucsf.edu
Mon Aug 24 17:48:25 PDT 2020

The CHIMERA/bin directory should not be on your path, nor should you run 
chimera when in the CHIMERA/bin directory.  As part of the installation 
process it asks  you where you want to put a symbolic link to the 
chimera binary on your PATH, e.g., if /usr/local/bin is on your PATH, 
then one of the choices will be /usr/local/bin/chimera.  If you didn't 
do that, then you need to use the full path to the chimera binary.   So 
go back to your home directory or a directory with the data you are 
working on, and run chimera from there.  You can make a symbolic link to 
the chimera binary anytime to make running it easier.

If that still doesn't work, then I would suspect that there is shared 
library that is missing.  Run:

     ldd /UCSF-chimera64-1.14/lib/python2.7/lib-dynload/_tkinter.so

And look for missing libraries.  Then use your Linux distribution's 
package manager to install it.  And please let everyone know which 
libraries are missing.  And also please share which version of Linux you 
are using.  With that information, we should be able to figure out which 
system packages are missing.



On 8/24/2020 5:07 AM, Smith Lee wrote:
> Dear All,
> From https://www.cgl.ucsf.edu/chimera/download.html I have downloaded 
> the chimera-1.14-linux_x86_64.bin, and have tried to install it 
> exactly based on the accompanied exact "Instructions”. After the 
> installation completed, I got to the bin folder, and try to launch 
> chimera with ./chimera. However her俄it says the installed 
> /UCSF-chimera64-1.14/lib/python2.7/lib-tk/Tkinter.py was not 
> configured for my python.
> Will you please let me know how to configure TK for my python, which 
> was a downloaded component of the chimera package?
> Best wishes,
> Smith
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
> Manage subscription: https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20200824/c7f5fb54/attachment-0001.html>

More information about the Chimera-users mailing list