[Chimera-users] Join models function on Chimera

Elaine Meng meng at cgl.ucsf.edu
Tue Jun 29 08:19:39 PDT 2021

Hi Roksana,
Just "#0:127.A at C #1:1.A at N"  is not a command, it is only a list of two atoms.  If you were trying to select them, and if those are really the correct specifiers for those atoms, the command would be

select  #0:127.A at C #1:1.A at N

Looking at your image, I believe you are making the common error of selecting the ribbon, which selects all of the atoms in the whole residues, not just the one atom per residue that you need to select in this case. Instead you have to hide the ribbon, show the backbone atoms, and then make sure ONLY those two atoms are selected. 

However, the "select" command above should work as an alternative to using the mouse, if it contains the correct specifiers for the carbonyl C of the last (C-terminal) residue of a chain in model #0 and the backbone N of the first (N-terminal) residue of a chain in model #1.

Here's an example that works with the C-N option of Join Models:

open 1zik
open 1gcn
display @n,ca,c,o
select #1:29.a at c #0:1.a at n

Then joining with C-N peptide bond option works, although I do get some error message about autochain that can be ignored (I will report that error).
I hope this helps,
Elaine C. Meng, Ph.D.                       
UCSF Chimera(X) team
Department of Pharmaceutical Chemistry
University of California, San Francisco

> On Jun 28, 2021, at 9:26 PM, Azad, Roksana via Chimera-users <chimera-users at cgl.ucsf.edu> wrote:
> Hi There,
> I hope you are doing very well. My name is Roksana Azad, I am a Ph.D. Student at the CUNY ASRC.
> I have been working on building a full length model of my protein into a cryoEM map, I have models for individual domain but not for the full lenght structure. I am trying to join the domain models using chimera "join models" function, but unfortunately it's not working for me. I tried everything I could find online about the issue, I used the addh command and kssdssp commands and also tried joining them using other bond instead of C-N, however my button for "apply" always grey and I can't click on it (please see the screenshot attached).
> I also tried this command "#0:127.A at C #1:1.A at N" according to my model # and atom, but its not selecting anything for me. I tried "combine" it also didn't work.​
> Please let me know if there is something else I am missing or what else I can do to create this bond or connection between two models.
> Thank you so much for your time and help in advance – very much appreciated.
> Sincerely,
> Roksana

More information about the Chimera-users mailing list