[Chimera-users] Bond-type error

Elaine Meng meng at cgl.ucsf.edu
Mon Oct 14 10:32:00 PDT 2019

Hi Laia,
>From looking at the PDB information for 2am9, I see that TES is testosterone.  

Notice in the chemical diagram in the link above that this molecule has double-bond to oxygen from the 6-membered ring.  However, the carbon-oxygen bond in this structure is longer than usual for a double bond, so the automatic atom-type recognition in Chimera instead assigns this oxygen as the O3 type which becomes hydroxyl OH when hydrogens are added. Then the Antechamber AM1-BCC charge calculation fails because it sees an inconsistency in the structure.

(I noticed that after hydrogen addition, there were two OH on the structure when there should only be one according to the chemical diagram.)

You can do either of these:

(1) delete the extra hydrogen (ctrl-click on it to select, then command “delete sel”) and then run charge calculation with Dock Prep again (make sure to NOT add hydrogens, i.e. uncheck that option so that the hydrogen doesn’t get put on again).  Also make sure to set charge of TES in add-charge dialog to 0, not  +1 which is the initial estimate.
(2) before adding hydrogens, change atom type of the atom named O3 from type O3 to type O2 (I can tell its name by pausing the mouse over it), e.g. command

setattr a idatmType O2 :TES at o3

… and then the hydrogens will be added correctly as expected for testosterone and the charge calculation will run.

It is sometimes necessary to look into the details of the chemical structures you are working with, since automatic procedures cannot handle everything.  I hope this helps,
Elaine C. Meng, Ph.D.
UCSF Chimera(X) team
Department of Pharmaceutical Chemistry
University of California, San Francisco

> On Oct 12, 2019, at 1:41 PM, Laia Ferrer Duran <laia.ferrerd at e-campus.uab.cat> wrote:
> Hi,
> I recently started using chimera for one project from university.
> At first I worked in the university computer that it had the program.
> Today, as I have to work from home I downloaded the latest version of chimera in the web page and I tried to do a dock prep in the protein from DB 2am9.
> With the receptor it worked well, but when I done it with the ligand TES it seems to have a problem with the add charges fase. 
> I searched first in all you webs and all it seems to say is that the molecular structure isn't correct but I really think there isn't a problem with the structure because with exactly the same steps it used to work in the university computer.
> The error says:
> (TES) sh: 1: C:/Program: not found
> (TES) /usr/bin/antechamber: Fatal Error!
> (TES) Cannot properly run "C:/Program Files/Chimera 1.14rc/bin/amber18/bin/bondtype -j part -i ANTECHAMBER_BOND_TYPE.AC0 -o ANTECHAMBER_BOND_TYPE.AC -f ac".
> Failure running ANTECHAMBER for residue TES
> Check reply log for details
> I don't know if it could be some problem with my program or if I should change the configuration of the program or what it is that isn't working.
> Thanks in advanced and I look forward you answer. 
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
> Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

More information about the Chimera-users mailing list