[Chimera-users] ImportError: No module named Chimera

Eiros Zamora, Juan j.eiros-zamora14 at imperial.ac.uk
Wed May 4 04:04:23 PDT 2016


I’m running a per-frame script to display the time in a MD movie. I used to run it without problems until I downloaded the new Mac OS X 64-bit 1.11 version. (I erased the old app, also tried to re-download the old version with no success).

More specifically, I load the MD movie, and in the command line I write: 2dlabels create timer text "0 ns" color white ypos .9 xpos .9 size 50
then I open a per-frame script with the following commands:
from Chimera import runCommand
runCommand("2dlabels change timer text '%.1f ns'" % (mdInfo['frame']*0.02))
and get the error:
Problem in per-frame script:
ImportError: No module named Chimera
I’ve googled it and found this reply:
[Chimera-users] How to install chimera as a python module

I’ve tried setting the $CHIMERA_PATH environment variable to /Applications/Chimera.app/Contents/Resources/share but I still run into the same problem.

Now, I don’t want to run the script directly from the command line, as it’s a per-frame script I have to run after I load the MD movie and create the 2dlabel object.

Anything obvious I’m missing here?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20160504/b47d0227/attachment.html>

More information about the Chimera-users mailing list