[Chimera-users] maintain .seg alignment to .mrc between sessions

Elaine Meng meng at cgl.ucsf.edu
Wed Mar 23 13:04:50 PDT 2016

Hi Amy,
I tried to reproduce this in simple tests but I didn’t have the problem.  Although (at least in my tests) the segmentation surfaces weren't restored automatically with the session, if I’d previously used “save segmentation” to save the segmentation to a file, I could just reopen it from the Segment Map menu and it was aligned properly with the map.

My only idea, however, is that perhaps the data set was moved separately at some point.  It may be possible to bring them back into register by  (A) copying the transformation of the map model to the segmentation model, e.g.

matrixcopy #N #M

… where N is the model number of the map and M is the model number of the segmentation  (see model numbers by showing the Model Panel from the Favorites menu).

or (B) by resetting all model positions, e.g. command:


If neither of those work, we may need to seek other opinions.  Our expert on staff is away for a couple of weeks, but others may have something to add. Best,
Elaine C. Meng, Ph.D.                       
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

On Mar 23, 2016, at 10:30 AM, Amy Jobe <abj2111 at columbia.edu> wrote:

> Hello,
> When I segment an 80S ribosome into individual ribosomal proteins and rRNAs, it takes some time and I often need to close and reopen my session.  Whenever I reopen my session, though, my .seg file is no longer aligned to my .mrc map, and I have to spend time manually (and probably slightly inaccurately) re-aligning them.  I've tried using the Associate Selected option in the daily build, although I'm not sure if it's meant to maintain alignment, and it hasn't fixed the problem.  Can anyone help me with this?  I'm using the daily build and the most recent stable version on Mac.
> Thanks,
> Amy Jobe

More information about the Chimera-users mailing list