[Chimera-users] Unrecognized command: "minimize"

Viachaslau Bernat viachaslau.bernat at medchem.uni-erlangen.de
Thu Aug 18 01:54:04 PDT 2011

Dear Chimera developers,

I've got a problem with scripting in chimera. By analogy with your 
example I've written a python script for geometry optimization of small 
library of ligands. In GUI mode all commands run smoothly as I type them 
into chimera command line. Nevertheless, when I try to run a script 
containing the same commands I get the error `unrecognized command: 
"minimize"`, no matter if I run it from GUI interface menu or with 
--nogui parameter.

Here is my testing script (test.py):

      import os
      import chimera
      from chimera import runCommand as rc
      from chimera import replyobj
      fn = "lib1.mol2"
      rc("open " + fn)
      rc("miminize nsteps 70000 stepsize 0.001 interval 100 freeze none
    nogui true")
      rc("write format pdb 0 min/" + fn + ".pdb")
      rc("close all")
      rc("stop now")

And here is the output from Python:

    ~/sublib> ~/chimera/bin/chimera --nogui test.py
    Executing test.py...
    Opening lib1.mol2...
    UNQ1 opened

    Traceback (most recent call last):
       File "/home/viachaslau/chimera/share/chimeraInit.py", line 677,
    in init
         chimera.openModels.open(a, prefixableType=1)
       File "/home/viachaslau/chimera/share/chimera/__init__.py", line
    1541, in open
         models = func(filename, *args, **kw)
       File "/home/viachaslau/chimera/share/chimera/__init__.py", line
    973, in _openPython
         loadFunc(sandboxName, fileName, f)
       File "test.py", line 8, in <module>
         rc("miminize nsteps 70000 stepsize 0.001 interval 100 freeze
    none nogui true")
       File "/home/viachaslau/chimera/share/chimera/__init__.py", line
    2235, in runCommand
         makeCommand(*args, **kw)
       File "/home/viachaslau/chimera/share/Midas/midas_text.py", line
    78, in makeCommand
         'Unrecognized command: "%s"' % cmd
    MidasError: Unrecognized command: "miminize"
    Error while processing test.py:
    MidasError: Unrecognized command: "miminize"

       File "/home/viachaslau/chimera/share/Midas/midas_text.py", line
    78, in makeCommand
         'Unrecognized command: "%s"' % cmd

    See reply log for Python traceback.

I run SUSE 11.3 as operating system and chimera is installed into ~/chimera/
I also tried to run commands row by row in IDLE window of chimera and 
found out that python suspends on runCommand("minimize ...") command

Viachaslau Bernat, PhD-student
Department Chemistry and Pharmacy
Schuhstrasse 19, 91052 Erlangen -- Germany
Phone: +49-9131-8522588

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20110818/3919afe1/attachment.html>

More information about the Chimera-users mailing list