<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">Hi Tom,<div class=""><span class="Apple-tab-span" style="white-space:pre">        </span>This seem to be an oversight in the code — it tries to remake the tool-instance menu when RESTServer starts, and it obviously shouldn’t in the headless version (and/or nogui mode). &nbsp; I have committed a fix to the code. &nbsp;Please try tomorrow’s daily build and see if it works better.</div><div class=""><br class=""></div><div class="">—Eric</div><div class=""><br class=""><div class="">
<div style="color: rgb(0, 0, 0); letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px; word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div class=""><span class="Apple-tab-span" style="white-space: pre;">        </span>Eric Pettersen</div><div class=""><span class="Apple-tab-span" style="white-space: pre;">        </span>UCSF Computer Graphics Lab</div><div class=""><br class=""></div></div></div><div><blockquote type="cite" class=""><div class="">On Mar 30, 2016, at 2:18 PM, <a href="mailto:tom@pine-biotech.com" class="">tom@pine-biotech.com</a> wrote:</div><br class="Apple-interchange-newline"><div class=""><div class="">Hi all,<br class=""><br class="">Using the unsupported headless linux x64 installer, chimera-1.10.2-linux_x86_64_osmesa.bin, I can run Chimera at the command line but am having a very difficult time running the RESTServer extension. Using my ~/.chimera/preferences file from my OS X install where a location for Extensions was selected in the preferences and saved, and copied to linux and edited to contain the /opt/UCSF/Chimera64-1.10.2/share location instead, it does open a bunch of packages on start, unlike before when it refused to load any extension. &nbsp;However, it still cannot start RESTServer.<br class=""><br class="">[root@dfw share]# chimera<br class="">Package "DBPuppet" already exists and tool(s) in it will not be loaded<br class="">[snip, for full output see <a href="http://pastebin.com/s3GH7mbz" class="">http://pastebin.com/s3GH7mbz</a> ]<br class=""><blockquote type="cite" class="">start RESTServer<br class=""></blockquote>Starting extension 'RESTServer' failed<br class=""><br class="">As such, the one reason I wanted to run Chimera headless on linux does not seem to work. &nbsp;I know it's unsupported so I'm not expecting anything, but perhaps this is something that can be resolved simply. I've done a few fruitless google searches and this mailing list kept coming up.<br class=""><br class="">Thanks for your time,<br class="">Tom<br class="">_______________________________________________<br class="">Chimera-users mailing list: <a href="mailto:Chimera-users@cgl.ucsf.edu" class="">Chimera-users@cgl.ucsf.edu</a><br class="">Manage subscription: <a href="http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users" class="">http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users</a><br class=""></div></div></blockquote></div><br class=""></div></body></html>