<div dir="ltr"><div><div><div>Thanks Tom, and thanks very much to you and Elaine both for the tips re using color zone with morph movies - interpolating the colors was indeed where I was running into trouble and it now looks beautiful!<br><br></div>Regarding the animation tool, it would be really great if there was a option to export a script directly from the animation tool to recreate the equivalent movie, as the interface is very handy for visualizing how everything fits together and one could then iterate and tweak the script - maybe for ChimeraX?<br><br></div>Cheers,<br></div>Oli<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Mon, Feb 1, 2016 at 9:15 PM, Tom Goddard <span dir="ltr">&lt;<a href="mailto:goddard@sonic.net" target="_blank">goddard@sonic.net</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word">Hi Oliver,<div><br></div><div>  Sounds like a Chimera memory leak.  I have made movies that use 100,000 atoms with 10,000 frames and not run out of memory.  But I always make my movies using a script, not the Animation tool.  The Animation tool is a prototype, it has many limitations and bugs, and it would not surprise me if it is eating up all the memory.</div><div><br></div><div><span style="white-space:pre-wrap">        </span>Tom</div><div><br></div><div><br><div><blockquote type="cite"><span class=""><div>On Jan 30, 2016, at 2:04 PM, Oliver Clarke  wrote:</div><br></span><div><span class=""><div dir="ltr"><div><div>Also, I&#39;ve noticed that if I try to record another movie in the same session of chimera after having recorded one already, I run out of memory very fast, whereas if I restart chimera and immediately reload the same session, I am able to record the same movie without a problem - I wonder if maybe there is a memory leak of some sort?<br><br></div>Cheers,<br></div>Oli<br></div></span><span class=""><div class="gmail_extra"><br><div class="gmail_quote">On Sat, Jan 30, 2016 at 12:44 PM, Oliver Clarke wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div><div><div>Hello,<br><br></div>I am consistently running out of memory when recording long-ish movies (using the Animation tool) on a Macbook pro with 16GB RAM. Admittedly there are a lot of atoms in the model I am using (~120,000), but most are not displayed (only ribbons).<br><br>Chimera is consistently crashing at about the 300 frame mark and looking at the activity monitor during the recording I can see memory pressure gradually increasing until Chimera freezes (which is generally not recoverable). <br><br>Is there any way to reduce the amount of memory required for movie recording? Will deleting all undisplayed atoms help? Is there some way to perform these operations on disk rather than in memory (most likely a silly question)?<br><br></div>Cheers,<br></div>Oli.<br></div>
</blockquote></div><br></div></span>
_______________________________________________<br>Chimera-users mailing list<br><a href="mailto:Chimera-users@cgl.ucsf.edu" target="_blank">Chimera-users@cgl.ucsf.edu</a><br><a href="http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users" target="_blank">http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users</a><br></div></blockquote></div><br></div></div></blockquote></div><br></div>