<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style></head>
<body class='hmmessage'><div dir='ltr'>Thank you Greg for your kind help.<br><div><font style="font-size: 12pt;" face="Verdana" size="3">For now, I don;t want to change my graphics card and I have latest graphics driver for Mesa, so I have decided to update OpenSUSE.<br>But is it necessary to install 13.2 ?<br>Can't I go for 13.1 ?<br>Is there any way to check which earliest version is compatible for my workstation and Chimera graphics ?<br><br></font></div><div><b style="font-family:Garamond;font-size:16pt;"><font color="#2672ec">Muhammad Sufian</font></b></div><br><br><div><hr id="stopSpelling">Date: Fri, 13 Mar 2015 09:17:07 -0700<br>From: gregc@cgl.ucsf.edu<br>To: msufian@outlook.com; chimera-users@cgl.ucsf.edu<br>Subject: Re: [Chimera-users] UCSF Chimera error: X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)<br><br>
  
    
  
  
    I'm sorry, the Matrix graphics is more of a hindrance than a help.&nbsp;
    It uses the software only OpenGL driver, Mesa, to do its 3D
    drawing.&nbsp; And the easiest way to get a newer version of Mesa on your
    system is to update it to OpenSUSE 13.2 or the latest Ubuntu.&nbsp; If
    you have the option of installing an AMD or NVIDIA graphics card in
    your system, do so, and install the proprietary driver.&nbsp; It will be
    like going from walking to driving a car -- much faster, and you can
    buy a budget car, a regular car, or race car, depending on your
    budget. :-)<br>
    <br>
    &nbsp;&nbsp;&nbsp; HTH,<br>
    <br>
    &nbsp;&nbsp;&nbsp; Greg<br>
    <br>
    <div class="ecxmoz-cite-prefix">On 3/13/2015 12:27 AM, Muhammad Sufian
      wrote:<br>
    </div>
    <blockquote cite="mid:BAY180-W15B8ABFBC7963404041EB0B7070@phx.gbl">
      <style><!--
.ExternalClass .ecxhmmessage P {
padding:0px;
}

.ExternalClass body.ecxhmmessage {
font-size:12pt;
font-family:Calibri;
}

--></style>
      <div dir="ltr">Dear Greg,<br>
        <br>
        I have tried debugging Chimera and the issue is related to
        OpenGL;<br>
        <br>
        <b><font style="" face="Courier New,sans-serif">sufian@system01:~&gt;
            chimera --debug</font><font style="" face="Courier              New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; initializing general preferences</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; loading Tix</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; initializing graphics</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; create application</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; loading Pmw</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; creating main window</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; creating menus</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; creating toolbar</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; creating viewer</font><font style="" color="#5133AB" face="Courier New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">&nbsp; initializing OpenGL</font><font style="" face="Courier New,sans-serif"><br>
          </font><font style="" face="Courier New,sans-serif">&nbsp;<font style="" color="#D24726"> X Error of failed request:&nbsp;
              BadDrawable (invalid Pixmap or Window parameter)</font></font><font style="" color="#D24726" face="Courier New,sans-serif"><br>
          </font><font style="" color="#D24726" face="Courier              New,sans-serif">&nbsp;&nbsp;&nbsp; Major opcode of failed request:&nbsp; 72
            (X_PutImage)</font><font style="" color="#D24726" face="Courier New,sans-serif"><br>
          </font><font style="" color="#D24726" face="Courier              New,sans-serif">&nbsp;&nbsp;&nbsp; Resource id in failed request:&nbsp;
            0x4000064</font><font style="" color="#D24726" face="Courier              New,sans-serif"><br>
          </font><font style="" color="#D24726" face="Courier              New,sans-serif">&nbsp;&nbsp;&nbsp; Serial number of failed request:&nbsp; 2678</font><font style="" color="#D24726" face="Courier New,sans-serif"><br>
          </font><font style="" color="#D24726" face="Courier              New,sans-serif">&nbsp;&nbsp;&nbsp; Current serial number in output stream:&nbsp;
            2682</font></b><br>
        <br>
        Then I checked for PCI as per your mentioned command;<br>
        <br>
        <b><font style="" face="Courier New,sans-serif">sufian@system01:~
            # lspci | grep VGA</font><font style="" face="Courier              New,sans-serif"><br>
          </font><font style="" color="#5133AB" face="Courier              New,sans-serif">03:00.0 VGA compatible controller: Matrox
            Electronics Systems Ltd. MGA G200EV</font></b><br>
        <br>
        I checked <font style="" color="#5133AB"><b><font style="" face="Courier New,sans-serif">yast2</font></b></font> for
        any driver update, and it was up to date. I don't want to switch
        to <b>OpenSUSE 13.2</b> for now. <br>
        Is there any earlier version of Chimera specific to my VGA ? I
        have also tried Chimera 1.8, but got same error.<br>
        <br>
        Kindly guide me.<br>
        <div><font face="Verdana" size="3"><br>
          </font></div>
        <div><font face="Verdana"><font face="Verdana" size="3"><br>
            </font></font></div>
        <div><b style="font-family:Garamond;font-size:16pt;"><font color="#2672ec">Muhammad Sufian</font></b></div>
        <br>
        <br>
        <div>
          <hr id="ecxstopSpelling">Date: Thu, 12 Mar 2015 12:58:00 -0700<br>
          From: <a class="ecxmoz-txt-link-abbreviated" href="mailto:gregc@cgl.ucsf.edu">gregc@cgl.ucsf.edu</a><br>
          To: <a class="ecxmoz-txt-link-abbreviated" href="mailto:msufian@outlook.com">msufian@outlook.com</a>; <a class="ecxmoz-txt-link-abbreviated" href="mailto:chimera-users@cgl.ucsf.edu">chimera-users@cgl.ucsf.edu</a><br>
          Subject: Re: [Chimera-users] UCSF Chimera error: X Error of
          failed request: BadDrawable (invalid Pixmap or Window
          parameter)<br>
          <br>
          Try running "chimera --debug", it should give a clue where in
          the initialization process chimera died.&nbsp; That said, it is
          most likely a graphics driver bug.&nbsp; Run "lspci | grep VGA" to
          see what kind of graphics card you have.&nbsp; Then, if OpenSUSE
          has a tool or package for that graphics card, install it.&nbsp; If
          not, if you have ATI/AMD or NVIDIA graphics, you will download
          the right driver from amd.com or nvidia.com, respectively, and
          install it.&nbsp; If you have Intel graphics, upgrade your system
          to OpenSUSE 13.2.<br>
          <br>
          &nbsp;&nbsp;&nbsp; Best of luck and please let me know if updating the
          graphics driver fixes the bug,<br>
          <br>
          &nbsp;&nbsp;&nbsp; Greg<br>
          <br>
          <div class="ecxmoz-cite-prefix">On 03/12/2015 05:10 AM,
            Muhammad Sufian wrote:<br>
          </div>
          <blockquote cite="mid:BAY180-W655B5B2B5871CE3AB47474B7060@phx.gbl">
            <div dir="ltr">
              <style><!--
.ExternalClass .ecxhmmessage P {
padding:0px;
}

.ExternalClass body.ecxhmmessage {
font-size:12pt;
font-family:Calibri;
}


--></style>
              <div dir="ltr"><font style="font-size:12pt;" face="Verdana" size="3">Dear all Chimera users,<br>
                  <br>
                  I tried to install following version of Chimera;<br>
                  <font style="" color="#5133AB"><b><font style="" face="Courier New,sans-serif">&nbsp;
                        chimera-1.10.1-linux_x86_64.bin</font></b></font><br>
                  <br>
                  but after installation, following error appeared after
                  its execution;<br>
                  <font style="" color="#5133AB"><b><font style="" face="Courier New,sans-serif">sufian@system01:/usr/local/chimera/bin&gt;

                        ./chimera</font><font style="" face="Courier                          New,sans-serif"><br>
                      </font><font style="" color="#D24726" face="Courier New,sans-serif">X Error of failed
                        request:&nbsp; BadDrawable (invalid Pixmap or Window
                        parameter)</font><font style="" color="#D24726" face="Courier New,sans-serif"><br>
                      </font><font style="" color="#D24726" face="Courier New,sans-serif">&nbsp; Major opcode of
                        failed request:&nbsp; 72 (X_PutImage)</font><font style="" color="#D24726" face="Courier                          New,sans-serif"><br>
                      </font><font style="" color="#D24726" face="Courier New,sans-serif">&nbsp; Resource id in
                        failed request:&nbsp; 0x2200064</font><font style="" color="#D24726" face="Courier New,sans-serif"><br>
                      </font><font style="" color="#D24726" face="Courier New,sans-serif">&nbsp; Serial number of
                        failed request:&nbsp; 1357</font><font style="" color="#D24726" face="Courier New,sans-serif"><br>
                      </font><font style="" color="#D24726" face="Courier New,sans-serif">&nbsp; Current serial
                        number in output stream:&nbsp; 1363</font></b></font><br>
                  <br>
                  I also tried to install Chimera 1.9, but got same
                  error. My system specifications are;<br>
                  &nbsp; Processor: x86_64 <br>
                  &nbsp; Operating-system: GNU/Linux (OpenSUSE 12.1)<br>
                  &nbsp; Kernel: Linux 3.4.63-2.44-desktop<br>
                  <br>
                  Kindly guide me how to resolve this issue.<br>
                  <br>
                  Regards.<br>
                </font>
                <div><font face="Verdana" size="3"><br>
                  </font></div>
                <div><font face="Verdana"><font face="Verdana" size="3"><br>
                    </font></font></div>
                <div><b style="font-family:Garamond;font-size:16pt;"><font color="#2672ec">Muhammad Sufian</font></b></div>
                <div><font color="#2672ec" face="Garamond">M.Phil.
                    scholar (Molecular Medicine),</font></div>
                <div><font color="#2672ec" face="Garamond">Computational
                    Biology Laboratory,</font></div>
                <div>
                  <div><font color="#2672ec" face="Garamond">Lab no.
                      P-103, PCMD-Extension,</font></div>
                  <div><font color="#2672ec" face="Garamond">Dr.
                      Panjwani Center for Molecular Medicine and Drug
                      Research</font></div>
                  <div><font color="#2672ec" face="Garamond">International

                      Center for Chemical and Biological Sciences</font></div>
                </div>
                <div><font color="#2672ec" face="Garamond">University of
                    Karachi, Karachi, Pakistan</font></div>
              </div>
            </div>
            <br>
            <fieldset class="ecxmimeAttachmentHeader"></fieldset>
            <br>
            <pre>_______________________________________________
Chimera-users mailing list
<a class="ecxmoz-txt-link-abbreviated" href="mailto:Chimera-users@cgl.ucsf.edu">Chimera-users@cgl.ucsf.edu</a>
<a class="ecxmoz-txt-link-freetext" href="http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users" target="_blank">http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users</a>
</pre>
          </blockquote>
          <br>
        </div>
      </div>
    </blockquote>
    <br></div>                                               </div></body>
</html>