<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <div class="moz-cite-prefix">Hi Bob,<br>
      <br>
      If it works as root, but not as a normal user, then there are two
      likely possibilites: (a) they are using different OpenGL libraries
      (libGL.so), or (b) a file/device permissions problem.&nbsp; And double
      check that your DISPLAY environment variable is ":0".&nbsp; Also note
      that most issues are solved by installing the proprietary AMD or
      NVIDIA graphics driver (using the Additional Drivers dialog), so
      if you aren't, do that first.&nbsp; My condolences if you have Intel
      graphics -- in that case I'd recommend updating to Ubuntu 13.04
      (or newer), the Intel Linux graphics driver is under heavy
      development and the newer versions are much better.<br>
      <br>
      A quick test, run glxinfo (from the mesa-utils package), both as
      root and as yourself.&nbsp; They should be the same, if not, then the
      differences are a big clue.<br>
      <br>
      To test the OpenGL library hypothesis, run (CHIMERA is the path to
      the Chimera installation):<br>
      <br>
      &nbsp;&nbsp;&nbsp; env LD_LIBRARY_PATH=CHIMERA/lib ldd CHIMERA/lib/_chimera.so<br>
      <br>
      both as root and as yourself.&nbsp; If they are not the same, figure
      out why.&nbsp; If they are the same, then check the permissions on
      every shared library listed.<br>
      <br>
      &nbsp;&nbsp;&nbsp; Please let me know what you try and if it fixes the bug,<br>
      <br>
      &nbsp;&nbsp;&nbsp; Greg<br>
      <br>
      On 07/16/2013 07:13 AM, Robert Wohlhueter wrote:<br>
    </div>
    <blockquote cite="mid:51E554FD.8070507@earthlink.net" type="cite">
      <meta http-equiv="content-type" content="text/html;
        charset=ISO-8859-1">
      <font size="+1">I've been using Chime<font size="+1">ra 1.5.3 <font
            size="+1">under Lin<font size="+1">ux <font size="+1">(Ubuntu

                12.04, 64-bit) without problems; that version I had
                installed<font size="+1"> as root, and<font size="+1">
                    is owned by root.&nbsp; Just now I updated to version
                    1.8, which, initially, I also installed as root.&nbsp;
                    But trying to run it (as non-root) gave me fairly
                    opa<font size="+1">que error messages<font size="+1">
                        (copied below).&nbsp; <font size="+1">On a hunch
                          that it was a <font size="+1">matter of
                            privilege, I tried running with `sudo` --
                            which works fine.&nbsp; <br>
                            <br>
                            <font size="+1">Since <font size="+1">it
                                was not obvious where the problem lay, I
                                cleaned out the installation, and
                                installed an<font size="+1">ew as a
                                  normal user (me).&nbsp; Accordingly, the
                                  whole installation directory tree is <font
                                    size="+1">owned by me.&nbsp; But still I
                                    can<font size="+1">not run it (same
                                      errors) as me, but only with
                                      `sudo`. Same user, same <font
                                        size="+1">start directory, appa<font
                                          size="+1">rently the same
                                          Python (2.7) as w<font
                                            size="+1">or<font size="+1">ks

                                              with v. 1.5.3.</font></font></font></font><br>
                                      <br>
                                      <font size="+1">I'm totally
                                        flummoxed!&nbsp; Can't imagine wh<font
                                          size="+1">ere the privilege
                                          hang-u<font size="+1">p is.&nbsp;
                                            Any hints where I should
                                            look?<br>
                                            <br>
                                            <font size="+1">Thanks,<br>
                                              <br>
                                              Bob Wohlhueter<br>
                                              <br>
                                              <font size="+1">*****************************<font
                                                  size="+1">C<font
                                                    size="+1">-</font>shell

                                                  ou<font size="+1">tput*******************</font></font></font><br>
                                              <font size="+1">chimera<br>
                                                <font size="+1">X Error
                                                  of failed request:
                                                  BadRequest (invalid
                                                  request code or no
                                                  such operation)<br>
                                                  <font size="+1">&nbsp;&nbsp; <font
                                                      size="+1">Major
                                                      opcode of failed
                                                      request:&nbsp; 128
                                                      (GLX)<br>
                                                      <font size="+1">&nbsp;&nbsp;
                                                        Minor opcode of
                                                        failed request:&nbsp;
                                                        198 ()<br>
                                                        <font size="+1">&nbsp;&nbsp;

                                                          Serial number
                                                          of failed
                                                          request:&nbsp; 2813<br>
                                                          <font
                                                          size="+1">&nbsp;&nbsp;
                                                          Current<font
                                                          size="+1">
                                                          serial number
                                                          in output
                                                          stream:&nbsp; 2813</font></font><br>
                                                        </font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font></font>
    </blockquote>
    <br>
  </body>
</html>