<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    (Forgot to send reply to whole list)<br>
    <div class="moz-forward-container"><br>
      <br>
      -------- Original Message --------
      <table class="moz-email-headers-table" border="0" cellpadding="0"
        cellspacing="0">
        <tbody>
          <tr>
            <th nowrap="nowrap" valign="BASELINE" align="RIGHT">Subject:
            </th>
            <td>Re: [Chimera-users] Chimera on a virtualbox</td>
          </tr>
          <tr>
            <th nowrap="nowrap" valign="BASELINE" align="RIGHT">Date: </th>
            <td>Tue, 05 Feb 2013 13:51:47 -0800</td>
          </tr>
          <tr>
            <th nowrap="nowrap" valign="BASELINE" align="RIGHT">From: </th>
            <td>Greg Couch <a class="moz-txt-link-rfc2396E" href="mailto:gregc@cgl.ucsf.edu">&lt;gregc@cgl.ucsf.edu&gt;</a></td>
          </tr>
          <tr>
            <th nowrap="nowrap" valign="BASELINE" align="RIGHT">To: </th>
            <td><a class="moz-txt-link-abbreviated" href="mailto:chris.wood@stfc.ac.uk">chris.wood@stfc.ac.uk</a></td>
          </tr>
        </tbody>
      </table>
      <br>
      <br>
      <meta content="text/html; charset=ISO-8859-1"
        http-equiv="Content-Type">
      <div class="moz-cite-prefix">Hi Chris,<br>
        <br>
        So what are you trying to do with Chimera inside a virtual
        machine?&nbsp; Presumably, you're not trying to use it graphically
        because virtualized graphics performance is usually abysmal.&nbsp;
        Chimera benefits immensely from direct access to the graphics
        hardware.&nbsp; So that leaves using Chimera as a server, and for
        that the headless version of Chimera is usually better -- the
        headless version uses a software implementation of OpenGL and
        thus avoids any driver issues.<br>
        <br>
        That said, this bug is still likely to be related to OpenGL
        support in VirtualBox.&nbsp; Make sure the computer that VirtualBox
        is running on has an up-to-date OpenGL graphics driver.&nbsp; It
        doesn't matter what VirtualBox does if the underlying system has
        a bad graphics driver.<br>
        <br>
        To confirm that the bug is in the graphics driver, get a
        backtrace of where the error occurs by using gdb as follows in a
        Terminal window (and assuming there is a symbolic link to the
        chimera binary on your path):<br>
        <br>
        &nbsp;&nbsp;&nbsp; % export CHIMERA=`chimera --root`<br>
        &nbsp;&nbsp;&nbsp; % export LD_LIBRARY_PATH=$CHIMERA/lib<br>
        &nbsp;&nbsp;&nbsp; % gdb $CHIMERA/bin/python2.7<br>
        &nbsp;&nbsp;&nbsp; (gdb) break_exit<br>
        &nbsp;&nbsp;&nbsp; (gdb) run $CHIMERA/share/__main__.py --debug<br>
        &nbsp;&nbsp;&nbsp; (gdb) bt<br>
        <br>
        The '%' and '(gdb)' parts are the shell and gdb prompts,
        respectively.&nbsp; The output from the bt command will probably be
        in Chimera's molecular drawing code (as opposed to drawing the
        UI).&nbsp; If you need help interpreting the chimera backtrace, you
        can send it to me. <br>
        <br>
        &nbsp;&nbsp;&nbsp; HTH,<br>
        <br>
        &nbsp;&nbsp;&nbsp; Greg<br>
        <br>
        On 02/05/2013 12:48 PM, <a moz-do-not-send="true"
          class="moz-txt-link-abbreviated"
          href="mailto:chris.wood@stfc.ac.uk">chris.wood@stfc.ac.uk</a>
        wrote:<br>
      </div>
      <blockquote
cite="mid:7BF0C7F486F2F04EACD95EF31F2841001611440D@EXCHMBX01.fed.cclrc.ac.uk"
        type="cite">
        <meta http-equiv="Content-Type" content="text/html;
          charset=ISO-8859-1">
        <meta name="Generator" content="Microsoft Word 14 (filtered
          medium)">
        <style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Verdana;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";
        mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p
        {mso-style-priority:99;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
code
        {mso-style-priority:99;
        font-family:"Courier New";}
pre
        {mso-style-priority:99;
        mso-style-link:"HTML Preformatted Char";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
span.HTMLPreformattedChar
        {mso-style-name:"HTML Preformatted Char";
        mso-style-priority:99;
        mso-style-link:"HTML Preformatted";
        font-family:"Courier New";
        mso-fareast-language:EN-GB;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";
        mso-fareast-language:EN-US;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
        <div class="WordSection1">
          <p class="MsoNormal">Hello all,<o:p></o:p></p>
          <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
          <p class="MsoNormal">I'm trying to run Chimera on VirtualBox.
            The installation completes fine, but when I try and run the
            program (<code><span
                style="font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;">cd</span></code>
            to the bin directory and run <code>./chimera</code>) I see<o:p></o:p></p>
          <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
          <p class="MsoNormal"><span
              style="font-size:10.0pt;font-family:&quot;Courier
              New&quot;;mso-fareast-language:EN-GB">X Error of failed
              request:&nbsp; BadDrawable (invalid Pixmap or Window parameter)<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="font-size:10.0pt;font-family:&quot;Courier
              New&quot;;mso-fareast-language:EN-GB">Major opcode of
              failed request:&nbsp; 72 (X_PutImage)<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="font-size:10.0pt;font-family:&quot;Courier
              New&quot;;mso-fareast-language:EN-GB">Resource id in
              failed request:&nbsp; 0x480006a<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="font-size:10.0pt;font-family:&quot;Courier
              New&quot;;mso-fareast-language:EN-GB">Serial number of
              failed request:&nbsp; 1382<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="font-size:10.0pt;font-family:&quot;Courier
              New&quot;;mso-fareast-language:EN-GB">Current serial
              number in output stream:&nbsp; 1388<o:p></o:p></span></p>
          <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
          <p class="MsoNormal">I've tried enabling / disabling hardware
            virtualization &amp; 3D acceleration, but to no avail.
            Although people do seem to have problems with chimera on a
            virtualbox, it normally seems to be a problem with OpenGL,
            which this doesn't seem to be.<o:p></o:p></p>
          <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
          <p class="MsoNormal">Has anyone seen this error before? Is
            there anything else I'm missing? I can&#8217;t even work out if
            it's a hardware, VirtualBox, or OS problem&#8230;<o:p></o:p></p>
          <p class="MsoNormal"><strong><span
style="font-size:10.0pt;font-family:&quot;Verdana&quot;,&quot;sans-serif&quot;"><o:p>&nbsp;</o:p></span></strong></p>
          <p class="MsoNormal"><strong><span
style="font-size:10.0pt;font-family:&quot;Verdana&quot;,&quot;sans-serif&quot;">System:</span></strong><o:p></o:p></p>
          <p class="MsoNormal">VirtualBox 4.2.4<br>
            Guest additions 4.2.4<o:p></o:p></p>
          <p class="MsoNormal">Guest OS: Ubuntu 12.04<br>
            Host OS: Windows 7 professional<o:p></o:p></p>
          <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
          <p class="MsoNormal">Thanks in advance!<o:p></o:p></p>
          <p class="MsoNormal">Chris<o:p></o:p></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB">-------------------<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB">Dr Chris
              Wood<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB">STFC
              Rutherford Appleton Laboratory<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB">Didcot<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB">OX11 0QX<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB"><o:p>&nbsp;</o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB"><a
                moz-do-not-send="true" class="moz-txt-link-abbreviated"
                href="mailto:chris.wood@stfc.ac.uk">chris.wood@stfc.ac.uk</a><br>
              <a moz-do-not-send="true" class="moz-txt-link-abbreviated"
                href="http://www.ccpem.ac.uk">www.ccpem.ac.uk</a><o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB"><br>
              Tel: +44(0)1235 567864<o:p></o:p></span></p>
          <p class="MsoNormal"><span
              style="color:black;mso-fareast-language:EN-GB">Tel:
              +44(0)7909 586624<br>
              Fax: +44(0)1235 567801</span><span
              style="color:black;mso-fareast-language:EN-GB"><o:p></o:p></span></p>
          <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
        </div>
        <br>
        <p>-- <br>
          Scanned by iCritical.</p>
      </blockquote>
      <br>
      <br>
    </div>
    <br>
  </body>
</html>