[Chimera-users] Problem running Chimera on MacBook

Elaine Meng meng at cgl.ucsf.edu
Fri Apr 8 17:05:20 PDT 2022

Hi Judy,
I'm still mystified, as the order of events in the tutorial works for me on my Macbook.

 Note that the commands in setup.com refer to models #0, #1, and #2. This assumes that the docked ligands are #0 (because the ras.mol2 file was supposed to be opened first), receptor is #1 to be colored aquamarine, and GCP is #2 to be shown as magenta ball-and-stick.  Further, setup.com shows all residues of receptor (#1) within some distance of any docked ligand (#0).

 If you open setup.com before the docked ligands, it doesn't do the setup as intended because the receptor will be #0 and GCP is #1, and there is no #2 at all until after you open ras.mol2.

This wouldn't prevent you from using the ViewDock interface, but the display may be suboptimal for understanding (multicolored ribbons, some sidechains near docked ligands not shown, etc.).

Elaine C. Meng, Ph.D.                       
UCSF Chimera(X) team
Department of Pharmaceutical Chemistry
University of California, San Francisco

> On Apr 8, 2022, at 11:37 AM, Levine, Judy via Chimera-users <chimera-users at cgl.ucsf.edu> wrote:
> Hello again, Elaine –
> Interestingly, it turned out that if I opened the setup file first and then opened ras.mol2 in ViewDock (tutorial says to open ras first, then setup), it worked fine. Guess I should have tried that before asking for help!
> Thanks again –
> Judy
> From: Elaine Meng <meng at cgl.ucsf.edu>
> Date: Friday, April 8, 2022 at 11:13 AM
> To: Levine, Judy <judith.levine at goucher.edu>
> Cc: chimera-users at cgl.ucsf.edu <chimera-users at cgl.ucsf.edu>
> Subject: Re: [Chimera-users] Problem running Chimera on MacBook
> Hi Judy,
> I don't know why there would be a problem with the ViewDock tutorial on your MacBook.  I could show ras.mol2 in ViewDock and run the  "setup.com" file fine on my MacBook (tried this morning with Chimera 1.16).  The ViewDock tutorial has existed for a long time and works with versions ranging from old to new, so it is unlikely that the version of Chimera is the problem.
> My only idea, other than something strange about your individual setup, is to make sure you saved setup.com as plain text.
> If running setup.com is where the freeze occurs, you could instead try entering the commands one by one into the command line.  The commands that setup.com contains are shown in the tutorial page.
> <https://www.rbvi.ucsf.edu/chimera/docs/UsersGuide/tutorials/vdtut.html>
> Or maybe you can just skip our tutorial and simply use ViewDock with your Swissdock output -- the Swissdock folks have a video tutorial on using the two together:
> <https://www.youtube.com/watch?v=CxHaAnI-LDQ>
> Although ChimeraX does have an analogous tool, ViewDockX, it is somewhat different, so the Chimera ViewDock tutorial would not pertain.  More importantly in your situation, ChimeraX does not read Swissdock output currently -- sorry about that.
> I hope this helps,
> Elaine
> -----
> Elaine C. Meng, Ph.D.
> UCSF Chimera(X) team
> Department of Pharmaceutical Chemistry
> University of California, San Francisco
> > On Apr 8, 2022, at 7:19 AM, Levine, Judy via Chimera-users <chimera-users at cgl.ucsf.edu> wrote:
> >
> > Hello all –
> >
> > I’m having trouble doing the ViewDock tutorial on my MacBook. I am able to open the ras.mol2 file in ViewDock, but when I then open the setup file the program freezes – and in fact the only way to exit the program at that point is to do a force quit. I have done it successfully several months ago and wanted to refresh my memory but now am experiencing this problem. I installed the latest version (1.16) in case that was the problem, but that didn’t help. I also considered using ChimeraX instead but was unable to figure out whether the ViewDock feature is available in that. I’m able to do the tutorial on my home desktop PC, but at work I only have the MacBook so it’s frustrating not to have Chimera working properly. Has anyone else experienced this problem?
> >
> > (In case it’s not obvious, I am quite the novice Chimera user. I’m using it in undergraduate biochemistry teaching, primarily to analyze results from SwissDock.)
> >
> > Thanks!
> > Judy Levine
> This email originated from outside of Goucher College. Do not click links or open attachments unless you recognize the sender and know the content is safe.
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
> Manage subscription: https://www.rbvi.ucsf.edu/mailman/listinfo/chimera-users

More information about the Chimera-users mailing list