[Chimera-users] [External] Re: in *.gro file, chimera takes CL atom as C (in compound) and gives it wrong color

Lei Qian leiqian-temple2 at outlook.com
Fri Feb 26 19:53:51 PST 2021

Hi Eric,
Thank you very much for your thorough explanation! I really appreciate it.

I tried to do some test. I found:
Chimera recognizes CL when CL shown as solvent in gro file:
1000CL    CL2000    x.xxx      x.xxx     x.xxx
But it cannot recognize CL when CL shown as "LIG" in gro file:
1000LIG    CL2000    x.xxx      x.xxx     x.xxx
And in LIG case, "Cl" or "CL" may not have much difference.

Thanks again for your kind reply!

From: Eric Pettersen <pett at cgl.ucsf.edu>
Sent: Tuesday, February 23, 2021 5:04 AM
To: Lei Qian <tuk04130 at temple.edu>
Cc: chimera-users at cgl.ucsf.edu BB <chimera-users at cgl.ucsf.edu>
Subject: [External] Re: [Chimera-users] in *.gro file, chimera takes CL atom as C (in compound) and gives it wrong color

Hi Lei,
There is no explicit indication of the chemical element type in a .gro file, so it's all guesswork.  Chimera assumes that atom names that begin with any of the letters C, O, P, S, H, or N are the corresponding single letter element type.  This prevents atom names like CA and HG from being interpreted as calcium and mercury, rather than carbon and hydrogen.
There aren't any great solutions.  One option is to read in the .gro file, write it out as a .mol2 file, then edit that file to change the atom type of the CL atoms to Cl, then read that back in.  Another is to select your CL atoms and use the "Modify Structure" tab of the Build Structure tool to change their element to Cl.


Eric Pettersen
UCSF Computer Graphics Lab

On Feb 18, 2021, at 8:30 PM, Lei Qian <tuk04130 at temple.edu<mailto:tuk04130 at temple.edu>> wrote:

Dear users,
Could I ask a question on chimera? Thanks!
I tried to open a gro file (small compound) using chimera. Like below:
... ...
    1  LIG   CL   18   x.xxx    x.xxx      x.xxx
    1  LIG  CL1   19   x.xxx    x.xxx      x.xxx
... ...
Although chimera shows the CL name "CL" when the cursor is above the atom, but the CL atom color is incorrect: the same as Carbon.
I tried to change the "CL" to "BR", and the chimera shows the correct color: dark red. It seems weird to me. Could you please give me any suggestions?

Chimera-users mailing list: Chimera-users at cgl.ucsf.edu<mailto:Chimera-users at cgl.ucsf.edu>
Manage subscription: https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20210227/f66ba70e/attachment.html>

More information about the Chimera-users mailing list