[Chimera-users] Chimera help submission

David Leeming david.leeming at student.manchester.ac.uk
Thu Feb 25 05:53:38 PST 2021

Dear Chimera users,
I'm attempting to write a chimera script to automate the process of calculating the relative exposure of residues as per this tutorial: https://www.cgl.ucsf.edu/chimera/docs/UsersGuide/surfnorm.html

The script I have is as follows:
rc('surface') #   defines areaSES of residues
rc('defattr C:/Users/Admin/Downloads/areaSESgxg.txt log 0') # define attribute using areaSESgxg.txt
for m in chimera.openModels.list(modelTypes=[chimera.Molecule]):
    for r in m.residues:
        r.relSESA = r.areaSES/ r.areaSESgxg

However, when I run this script, I am receiving this error:
When I run the process using the UI I can successfully calculate relSESA
By using the command: "surface"
Then using the assign attribute function to assign areaSESgxg.txt
Followed by using the calculate attribute function to calculate per residue: residue.areaSES/ residue.areaSESgxg

Could you advise on any methods I could use to fix this script to produce the output I am receiving from the UI.

Kind regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20210225/d871993c/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Outlook-1he3xhiv.png
Type: image/png
Size: 96706 bytes
Desc: Outlook-1he3xhiv.png
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20210225/d871993c/attachment-0001.png>

More information about the Chimera-users mailing list