[Chimera-users] Chimera: Per-model clipping and contour level

Selenschik, Philipp pselensc at uni-muenster.de
Tue Oct 27 08:53:56 PDT 2020

Hey Elaine,

thanks for your reply! 

I attached my problem (1):
Image 1 shows the "per model clipped" density map. This works, but I also want the subunits to be clipped the same way. There are 24 of them fitted to the map. 
Image 2 shows an attempt to also clip one representative structure. This is what happens when I click "enable clipping" and works only partially. That is what I meant in my previous mail.
Image 3 shows the result for "orient plane perpendicular to line of sight" after enabling the clipping.

Concerning (2):

Yes, I slided through the contour level to match the measured volume with the expected one.

Kind regards


Institute of Medical Physics and Biophysics
Cellular Biophysics
Robert-Koch-Str. 31
48149 Münster

Tel.: +49-251-8355100
Fax: +49-251-8355121

-----Ursprüngliche Nachricht-----
Von: Elaine Meng <meng at cgl.ucsf.edu> 
Gesendet: Montag, 26. Oktober 2020 19:47
An: Selenschik, Philipp <pselensc at uni-muenster.de>
Cc: chimera-users at cgl.ucsf.edu
Betreff: Re: [Chimera-users] Chimera: Per-model clipping and contour level

Hi Philipp,
We're glad you like Chimera!  Sorry for the problems.

For problem (1) I don't know what you mean by "clipping works only partially."  Would need a picture, perhaps, or maybe it is simply that per-model clipping is not activated for all the models you wanted to clip.  Yes, you would have to turn Per-Model Clipping on for each model that you want to clip.  If tedious with the dialog, maybe easier to do so with the "mclip" command since you could specify more than one model at a time in the command.

For (2) it sounds like you are trying to get the enclosed volume to a certain size based on the molecular weight of your protein.  However, the contour level units as shown in the Volume Viewer histogram do not report the enclosed volume, they are just in whatever units your map file contains.  So to get the enclosed volume for a specific contour level, you would have to measure it each time you change the contour level, with the Measure Volume and Area tool or the "measure volume" command.  (Maybe you did that, but I couldn't tell from your description.)   

When it shows the whole cube, it might be that the contour level is so low it just includes your whole map grid. Maybe you could try command "volume all capFaces false" to see if that helps:

If it's not possible to get the size (enclosed volume) you expect, it may be related to data resolution, whether the surface is smoothed, whether "dust" is hidden, etc.  Since you said apoferritin I would expect very high resolution, however.

I hope this helps,
Elaine C. Meng, Ph.D.                       
UCSF Chimera(X) team
Department of Pharmaceutical Chemistry
University of California, San Francisco

> On Oct 26, 2020, at 8:47 AM, Selenschik, Philipp <pselensc at uni-muenster.de> wrote:
> Hello,
> I really enjoy working with Chimera (version 1.14), however I encounter two  problems:
> I fitted the X-ray based crystal structure of apoferritin to my cryo-EM density map, determined the symmetry and based on that the algorithm fits 24 subunits to the map. Really nice.
> Now I would like to show a “sliced” image of both map and structure. I tried doing so by “Side view”, enabling “clip”. That works, but I would like to rotate the clipped object.
> Then I tried per-model-clipping. Here I can clip the map and structures separately. However, I have to choose all fitted (e.g. 12 out of 24) substructures and the clipping works only partially.
> What am I doing wrong?
> Also, I tried to figure out the best contour level setting. It seems 
> there is no guide as to which is ideal? Based on a tutorial, I assumed 1 A³/Da for a globular protein, which turns out to be around 620*10³ A³ for my protein. The problem here is: If I slide beyond approx.. 550*10³ A³ all that remains is a square. What’s wrong?
> I hope you can help me out J
> Kind regards
> Philipp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: ApoF-1.png
Type: image/png
Size: 772610 bytes
Desc: ApoF-1.png
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20201027/e29503cf/attachment-0003.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ApoF-2.png
Type: image/png
Size: 764684 bytes
Desc: ApoF-2.png
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20201027/e29503cf/attachment-0004.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ApoF-3.png
Type: image/png
Size: 754075 bytes
Desc: ApoF-3.png
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20201027/e29503cf/attachment-0005.png>

More information about the Chimera-users mailing list