[Chimera-users] measure rotation

Tom Goddard goddard at sonic.net
Mon May 11 15:46:04 PDT 2020

Hi Jesse,

  It sounds like you are using "measure rotation" correctly.  The only way for us to figure out your case would be for you to send us a session file.  Use Chimera Help / Report a Bug... and attach a session file that has your two subunits where "measure rotation" gives a completely unreasonable result.  My guess would be that "measure rotation" is working, and I am suspicious that "clone the subunit" is giving you a second subunit with a different coordinate system.  You might explain how you "clone the subunit" -- is it just opening a second copy of a PDB?


> On May 11, 2020, at 2:56 PM, Jesse M. Hansen <jhansen6 at uw.edu> wrote:
> hi Elaine
> thanks for your response.
> Yes I think I am using the command correctly.  Sometimes it works but other times it doesn't, so there is clearly something I am missing.  It seems arbitrary why it works sometimes and not others, and then why the axis seems to be positioned near my protein or other times about 50 protein lengths away.  It's baffling.
> But yes my protein is helical, so imagine you have actin.  I load the map and the model for 1 subunit.  I then clone the subunit and fit it into the adjacent position then ask what the rotation is between those two models.  As I said it sometimes works, but not always.  Just wondering what it is I could be doing wrong.  I alway position the model in the center of the box, I try loading model or map first to see if results vary.  Nothing seems to help.  Why does the axis appear way off to the side in some cases?
> thanks again
> From: Elaine Meng <meng at cgl.ucsf.edu <mailto:meng at cgl.ucsf.edu>>
> Sent: Monday, May 11, 2020 2:23 PM
> To: Jesse M. Hansen <jhansen6 at uw.edu <mailto:jhansen6 at uw.edu>>
> Cc: chimera-users at cgl.ucsf.edu <mailto:chimera-users at cgl.ucsf.edu> <chimera-users at cgl.ucsf.edu <mailto:chimera-users at cgl.ucsf.edu>>
> Subject: Re: [Chimera-users] measure rotation
> Hi Jesse,
> I'm not sure, but it *might* be a misunderstanding of what this command does. 
> <http://www.rbvi.ucsf.edu/chimera/docs/UsersGuide/midas/measure.html#rotation <http://www.rbvi.ucsf.edu/chimera/docs/UsersGuide/midas/measure.html#rotation>>
> This command does not evaluate how to best fit or match the two models. It reports the current rotation and translation between the coordinate systems of the two models, which would be zero unless one model was moved relative to the other, either manually or with some other tool or command such as Fit in Map, match, or matchmaker. (Moving everything collectively, such as rotating or zooming to get a better view, does not change the positions of models relative to each other.)
> Centering just moves the view and doesn't change the coordinates of the structure.
> Imagine you have two copies of the protein, one before fitting and one after fitting.  Is the rotation between the two really around an axis that falls inside the protein?
> I may have misapprehended the situation, but this command is commonly misunderstood.
> Elaine
> -----
> Elaine C. Meng, Ph.D.                       
> UCSF Chimera(X) team
> Department of Pharmaceutical Chemistry
> University of California, San Francisco
> > On May 8, 2020, at 3:38 PM, Jesse M. Hansen <jhansen6 at uw.edu <mailto:jhansen6 at uw.edu>> wrote:
> > 
> > hi
> > 
> > I repeatedly have this issue and no idea how to fix it.  I send the same files to colleague and they cannot reproduce it.  We cannot figure out whether it's some minor detail I am doing, or it's my version of chimera.
> > 
> > When I try "measure rotation #1 #2" the axis ends up either pretty off center or WAY far away (like 20 protein widths away).  
> > 
> > have tried:
> >        • centering volume and resaving, fitting models into map and resaving.  Opening and all looks correct. 
> >        • tried opening pdb first then maps, or maps first then pdb. Both seem to give different results but neither are precisely down the actual axis of my helical protein despite having centered it.
> >        • adding "coordinateSystem #" to the command has no effect.  The axis that appears is now as long as my box, but it's still not centered
> > 
> > thanks
> > Jesse
> > _______________________________________________
> > Chimera-users mailing list: Chimera-users at cgl.ucsf.edu <mailto:Chimera-users at cgl.ucsf.edu>
> > Manage subscription: https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users <https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users>
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu <mailto:Chimera-users at cgl.ucsf.edu>
> Manage subscription: https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users <https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20200511/dbb3b925/attachment-0001.html>

More information about the Chimera-users mailing list