[Chimera-users] problem picking atoms in graphic window

Tom Goddard goddard at sonic.net
Thu Nov 14 16:01:49 PST 2019

Hi Roger,

  Your problem picking in Chimera probably means your computer does not have an adequate graphics driver installed.  The fix is to install a graphics driver.  To see if this is the problem use Chimera menu Help / Report a Bug.  Under "Gathered Information" if it says
OpenGL Vendor: Microsoft Corporation
OpenGL Renderer: GDI Generic
OpenGL Version: 1.1.0
then this means you only have OpenGL 1.1 graphics driver support (circa 1990s) and Chimera needs more modern graphics support to allow picking atoms and showing atom popup balloons (both uses the same graphics capability to pick what is under the mouse).

  A day or two ago I improved the Chimera daily build to warn about this problem when you start Chimera.  But the only way to fix it is install a graphics driver.


> On Nov 14, 2019, at 2:55 PM, Wartell, Roger M wrote:
>  Hi, 
>  I have a peculiar but simple problem using Chimera [version 1.13.1(build 41965)] on a Windows 10 PC-computer]. Using it to model docking of  small molecules to an RNA using autodock vina. This has worked fine.
>  Recently wanted to measure distances by control-click on atom 1 and control-shift-click on atom 2 (picking the atoms in graphic window). Nothing came up in 'Structure Measurement' box when I  'picked' the atoms and clicked on Create except for it telling me I had to pick atom 1 and atom 2. 
> If I hold the 'control' key of the keyboard down and move the mouse's hand symbol around an atom, the green outlined shape does not remain when I lift my finger from the mouse. On the right side of the bottom bar of the screen it says 'selection cleared' which disappears in a few seconds.  When one holds both control and shift keys down and encircle the green shape around an atom, the outline remains. Control click in an empty area removes it, as it should.
> A postdoc in an adjacent lab who uses Chimera took a look and was puzzled since her downloaded version on her computer works fine in picking atoms etc. She also was puzzled since my mouse arrow when moved over an atom/residue did not show what residue it was, which apparently it should. We tried several pdb files (proteins and an RNA) and they all behave the same.
> We checked under Preferences that the matrix of radio buttons for my mouse's actions were set the same as hers. Is there some other preference setting I do not  have set properly?  Everything the mouse should be doing with regard to moving/rotating molecules is as expected, and the program otherwise appears to work fine. 
> Any/all suggestions on solving this 'picking' atoms problem are most welcome.  
> Thank you and the others at UCSF who have developed Chimera. 
> Best
> Roger 
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu <mailto:Chimera-users at cgl.ucsf.edu>
> Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users <http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20191114/c1188151/attachment.html>

More information about the Chimera-users mailing list