[Chimera-users] --nogui gets permission denied when fetching pdb id

Ryan Harlich ryanharlich at hotmail.com
Tue Jul 30 12:46:44 PDT 2019

I get this.

Opening 1a1x...
[Errno 13] Permission denied: '1a1x'

It actually worked in a new folder. But then when I ran my python script it did not work. Then I tried doing it via command line instead of python script and I got the permission denied again.

Ryan Harlich

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

From: Greg Couch <gregc at cgl.ucsf.edu>
Sent: Tuesday, July 30, 2019 12:42:09 PM
To: chimera-users at cgl.ucsf.edu BB <chimera-users at cgl.ucsf.edu>; Eric Pettersen <pett at cgl.ucsf.edu>; Ryan Harlich <ryanharlich at hotmail.com>
Subject: Re: [Chimera-users] --nogui gets permission denied when fetching pdb id

"permission denied" is usually because you don't have write permission for some directory.  Run the "system pwd"  command to see which directory chimera is running in.  You also need permission for a temporary directory and the download directory.  As Eric alluded, the directory that is causing the problem should be obvious from the full error message.



On 7/30/2019 12:31 PM, Eric Pettersen wrote:
I wouldn’t be able to say without the actual full error output.

Eric Pettersen
UCSF Computer Graphics Lab

On Jul 30, 2019, at 12:01 PM, Ryan Harlich <ryanharlich at hotmail.com<mailto:ryanharlich at hotmail.com>> wrote:

Hi Chimera,

I am trying to run a script with the –nogui option and run command “open 1a1x” and I get permission denied. It works with the GUI so I am not sure why it is not working with –nogui.

Ryan Harlich

Sent from Mail<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3FLinkId%3D550986&data=02%7C01%7C%7C7c03b69fdc8949cec3c008d715260518%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637001125346767145&sdata=qX9OBe3QoGFYYUUMEddkaN3oY1%2FgfL4DEb0hwB4GFzg%3D&reserved=0> for Windows 10

Chimera-users mailing list: Chimera-users at cgl.ucsf.edu<mailto:Chimera-users at cgl.ucsf.edu>
Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users<https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fplato.cgl.ucsf.edu%2Fmailman%2Flistinfo%2Fchimera-users&data=02%7C01%7C%7C7c03b69fdc8949cec3c008d715260518%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637001125346777150&sdata=ggD%2BJXTITkRrEXVQzDGWjgCOJghYMXTmgDvi6vRxUZI%3D&reserved=0>

Chimera-users mailing list: Chimera-users at cgl.ucsf.edu<mailto:Chimera-users at cgl.ucsf.edu>
Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users<https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fplato.cgl.ucsf.edu%2Fmailman%2Flistinfo%2Fchimera-users&data=02%7C01%7C%7C7c03b69fdc8949cec3c008d715260518%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637001125346787161&sdata=fYxrhPbOeV41cPd%2FiKfFu9Mu5lEuIutP%2BGsdqPwLM2s%3D&reserved=0>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20190730/1d1906a8/attachment.html>

More information about the Chimera-users mailing list