[Chimera-users] MD movie metafile

Elaine Meng meng at cgl.ucsf.edu
Fri Oct 12 11:28:27 PDT 2018

Hi Matthias,
Now I see that the documentation says the metafile should contain paths relative to the metafile location, so I’m not absolutely sure that it will work to include the absolute paths as in my previous reply.

Instead (and how I usually do it) is to omit paths within the metafile and just put the metafile in the same place as the data.  E.g. metafile contents


and then use command something like 

open md:D:\metafile-name

I’m told the open command should be able to interpret the second colon correctly as indicating the drive.  If not, could try “cd” first as mentioned below.

> On Oct 12, 2018, at 11:03 AM, Elaine Meng <meng at cgl.ucsf.edu> wrote:
> HI Matthias,
> Sounds like you almost had it right.  However, you have to use the “open” command to open the metafile.  The “md” part is just a format specifier for the open command, not a command in itself.
> (command list: <http://www.rbvi.ucsf.edu/chimera/docs/UsersGuide/framecommand.html>)
> Summary:
> To bypass the MD Movie input-files dialog you would create a “metafile” which is just a short plain text file of the same things you would enter into that dialog.  The "startup and input" section of the MD Movie help has a couple examples of metafile contents:
> <http://www.rbvi.ucsf.edu/chimera/docs/ContributedSoftware/movie/framemovie.html>
> Your metafile would just contain something like this:
> namd(prmtop/dcd)
> D:\structure.psf
> D:\structure_MD001.dcd
> …and you’d open it with command:
> open md:metafile-name
> …where metafile-name is a pathname if it is not in the current working directory.  However, I suspect that pathname with a colon might cause problejms. Chimera command “cd” changes the current working directory, so if giving the pathname directly in the open command causes a problem, instead use “cd” to go that folder and then just use the metafile name in the open command.   I’m a little uncertain of what you’ll need to do, since I’m not a Windows user.  On Mac, all my pathnames don’t have colons in them so it’s not an issue.
> I hope this helps,
> Elaine
> -----
> Elaine C. Meng, Ph.D.                       
> UCSF Chimera(X) team
> Department of Pharmaceutical Chemistry
> University of California, San Francisco
>> On Oct 11, 2018, at 7:58 PM, Matthias Fellner <matthias.fellner at otago.ac.nz> wrote:
>> Good day
>> I successfully loaded NAMD psf/dcd files into chimera (version 1.13.1) using the tools MD movie interface. As I have many runs and each has multiple dcd files I wanted to use a script to load the different runs, instead of manually picking all the files through the interface each time. I tried to follow the limited instructions of the MD Movie homepage but failed to get anywhere.
>> I tried some versions of this command:
>> md: D:\script.txt or movie: D:\script.txt
>> The command md appears to try to start MDA (MultiDomain Assembler), the command movie wants some other unrelated inputs.
>> I am also not sure if the script command would even work like this:
>> namd(psf/dcd)
>> D:\structure.psf
>> structure_MD001.dcd - D:\
>> Any advice is appreciated
>> Thank you
>> Matthias Fellner
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
> Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

More information about the Chimera-users mailing list