[Chimera-users] substituting atoms

simon chapman rowanlodge19 at gmail.com
Mon Mar 5 06:45:00 PST 2018

Hello Elaine and Eric...nothing to worry about, just updating you with some
useful info.

The difficulties I had with continuation runs in Chimera took several weeks
to resolve, but now I can get to ~200ps as opposed to the 5ps value of a
standard run.

The problem lies in the Prep Structure interface  (attached). The
instruction "Input restart-trajectory file from previous
equilibration/production" would reasonably be interpreted as inputting the
restart-trajectory file from an earlier run? This file is generated after
each run and is posted on the desktop. However, it's never accepted, and
the error message I mentioned in an earlier email pops up every time.

It actually needs to have a suffix <01. Which is very odd,as such a file
doesn't actually exist until the run is over!  Adding a suffixes of unit
value higher to the output files is however logical.

It might be just ambiguous interface design, something that slipped thru
the net, but the problem is very simply resolved by this method. If only it
hadn't taken me weeks to stumble on it!

Still very happy with Chimera, getting excellent data for my dissertation.
  Best wishes    Simon

On 17 January 2018 at 18:38, Elaine Meng <meng at cgl.ucsf.edu> wrote:

> As I understand it, the message is that the molecules in the input restart
> file are not the same as the current molecules (not exactly the same set of
> residues, atoms, bonds).  Changing the filenames would allow for a
> completely separate run, but it would not solve the problem of continuing
> the same simulation if the chemical system is different.   How it might be
> different, I don’t know.  All I can say is if you changed something between
> the runs, don’t do that.
> Elaine
> > On Jan 17, 2018, at 4:33 AM, simon chapman <rowanlodge19 at gmail.com>
> wrote:
> >
> > Hello Eric and Elaine. Chance of earning a second pint of ginger beer if
> you wish...
> >
> > Simulations and analysis going very well, I have substituted all 12
> oxygens for sulphur. Each requires a new name: UNK I, UNK2 etc. Advice for
> others...naming will only alow digits 1 to 9. so for 12 iterations, I used
> zero and the original unappended "UNK". Which makes 12. I have also
> successfully set production for 50000steps, equivalent to 8ps.
> >
> > However, there appears to be an option for continuation from one run to
> a subsequent one. I've tried for a few days now, but get the same error
> message every time ('continuation2 attachment').  Changing file names as
> described in the message doesn't work. It's probably something simple
> (probably me in fact), but would really appreciate your comments.
> >
> > Best wishes   Simon
> >
> >
> >
> > On 10 January 2018 at 19:01, Eric Pettersen <pett at cgl.ucsf.edu> wrote:
> > Great!  If we’re in the neighborhood I’ll take a pint of ginger ale. :-)
> >
> > —Eric
> >
> >
> >> On Jan 10, 2018, at 4:09 AM, simon chapman <rowanlodge19 at gmail.com>
> wrote:
> >>
> >> Hello Elaine and Eric. Thankyou for the prompt reply....and I'm very
> impressed! Eric's suggestion #2 worked!
> >>
> >> I assumed the protonation was OK as I ran the PDB downloaded structure
> through a protonation webserver (H++).  So I just changed the name of the
> novel substitution. It looks like additional alterations will also need
> renaming: I ran the next substitution in the incremental progression( #5)
> as "UNK3",and that is just about to complete.
> >>
> >> I am especially pleased as the data are definitely tending to support
> my hypothesis. You will acknowledged in the Methodology section of my
> dissertation.
> >>
> >> So, thanks again. There's a charming 14th century pub just down the
> lane from me...buy you both a pint next time you're passing through
> >>
> >> Best wishes   Simon
> >>
> >> On 9 January 2018 at 19:31, Eric Pettersen <pett at cgl.ucsf.edu> wrote:
> >> Hi Simon,
> >>      Everything Elaine says is true.  I do have some last ditch
> suggestions for you though.  One thing is that the fourth guanine differs
> in protonation state from the others in that the fourth one either has or
> lacks an HO3’ whereas the others don’t.  You should investigate why this is
> the case.  The two possibilities are then:
> >>
> >> 1) The protonation difference is an error.  You would need to correct
> the structure so that all four guanines start with the same protonation.
> >> 2) For some reason the protonation difference is okay.  You then need
> to give the modified version of the fourth guanine a different name from
> the others, e.g. “UK2” instead of “UNK”.  Not guaranteeing this will work,
> but it might.
> >>
> >> —Eric
> >>
> >>      Eric Pettersen
> >>      UCSF Computer Graphics Lab
> >>
> >>
> >> On Jan 9, 2018, at 10:24 AM, Elaine Meng <meng at cgl.ucsf.edu> wrote:
> >>>
> >>> Hi Simon,
> >>> I think you may be stretching the tools beyond their intended
> purposes: Chimera’s minimization, molecular dynamics interface, and
> automatic parametrization of nonstandard residues with Antechamber are
> meant to provide relatively simple access to such calculations by
> noncomputational scientists, given the large learning curves of dedicated
> simulation packages like GROMACS, AMBER, etc. These tools can be highly
> useful to clean up structures or suggest additional reasonable
> conformations. However, they are not meant for precise quantification of
> energies or for very long simulations, especially not in conjunction with
> nonstandard residues with parameters estimated by Antechamber.  The
> Gasteiger charges are very quick-and-dirty, so I would caution against
> overinterpreting simulations that employ them.  Further, Antechember is
> meant to cover most small organic molecules but not every possible molecule.
> >>>
> >>> It seems that the modified UNK residues fall into two structural types
> (as per the “specify net charges” dialog), and that one (maybe just the
> 4th?) fails in parametrization by Antechamber, and then the Solvate or Add
> Ions tool cannot find some parameter needed for its calculation. These
> tools come from the Ambertools package even though they are included with
> Chimera and Chimera has interfaces to them.  I don’t know exactly what the
> problem is, nor do I have a solution, sorry.
> >>> Elaine
> >>> -----
> >>> Elaine C. Meng, Ph.D.
> >>> UCSF Chimera(X) team
> >>> Department of Pharmaceutical Chemistry
> >>> University of California, San Francisco
> >>>
> >>>
> >>>> On Jan 9, 2018, at 1:30 AM, simon chapman <rowanlodge19 at gmail.com>
> wrote:
> >>>>
> >>>> Hello Elaine, sorry to bother you again.
> >>>>
> >>>> Chimera has been a real treat so far, but I have hit a problem. I've
> struggled for a week now, and finally given up!
> >>>>
> >>>> I am incrementally substituting S for O on four guanines in a regular
> complex. 3 substitutions work fine in a simulation and producing very
> encouraging data (attachment 1) But 4 substitutions (attachment 2) triggers
> a load of error messages. The first is attachment 3. After solvation,
> attachment 4 appears and the solvation box is removed if neutralising ions
> are added. If ions not added, attachment 5 warning appears.  Not sure if
> attachment 6 is relevant.
> >>>>
> >>>> Hope you can help/advise?
> >>>>
> >>>> Best wishes   Simon
> >>>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20180305/93f25579/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: prod phase for chimera team.png
Type: image/png
Size: 42329 bytes
Desc: not available
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20180305/93f25579/attachment.png>

More information about the Chimera-users mailing list