[Chimera-users] Showing/Hiding/Fading

Elaine Meng meng at cgl.ucsf.edu
Wed Jun 13 10:48:39 PDT 2018

Hi Gustaf,

> On Jun 13, 2018, at 12:35 AM, Gustaf Olsson <gustaf.olsson at lnu.se> wrote:
> So, the commands suggested does work for creating a surface and hiding it though I am right back at not working even when using separate models. I cannot figure out what I am doing wrong here.
>    surfcat templ #1:17.het
>    surf probeRadius 0.5 vertexDensity 20.0 templ; coulombic -5 red 0 white 5 blue templ
>    ~surf templ
>    surf templ
> Running this creates a surface, colors it by charge and hides it, though now when I show the surface again it is all white. I understand that i need to re-issue the entire "surf probeRadius 0.5 vertexDensity 20.0 templ; coulombic -5 red 0 white 5 blue templ” command to show the exact same surface with desired colors again though this is not really what I was looking for. Hence, creating the surface, making it 100% transparent and then fading it in would be what I want.

The reason the surface turns white is because it has to be recalculated if you use diffferent probe radius and/or vertex density.  When you first made the surface it was with nondefault probe radius and vertex density.  If you use the same probe radius and vertex density when you show it again (with “surf”) it will not trigger the recalculation and you will still have the Coulombic coloring. I.e., use this to reshow the surface in order to keep the coloring:

~surf templ
surf probeRadius 0.5 vertexDensity 20.0 templ

… or if it’s the only surface of model #0, could hide/show with the following instead:

~modeldisp #0 & ~ @*
modeldisp #0 & ~ @*

> This dis not possible for me since I cannot manipulate the transparency of this surface using either “transparency” or “surfacetransparency” commands. What worked with my “broke” models before does not work at all now. These commands either do nothing or only affects 17.het structure and not the created surface. How do I specify the surface and make it transparent to be able to fade it in again?
> The single molecule (17.het) is now model #1 and the only structure in that model. I run the command as stated above (using surfcat or just specifying the #1 or #1:17.het all produces the exact same result and issue) and end up with two “model #1”, the structure and the surface. I cannot modify the transparency of the surface at all, none of these commands work:
>    transp 100,s templ
>    transp 100 templ
>    transp 100 #1
>    transp 100 #1:17.het
>    transp 100 :17.het
>    surftransparency 100 templ
>    surftransparency 100 #1
>    surftransparency 100 #1:17.het
>    surftransparency 100 :17.het
> Using the GUI works just as intended so obviously I am the issue and I’m obviously not using the correct syntax, so how do I do this correctly?

The issue is not the syntax ( and “surftransparency” is exactly the same as “transparency” with “,s” after the value so no need to try both) but that the Coulombic-colored surface is in a different coloring mode that does not allow transparency to be adjusted.  It will work fine on surfaces that haven’t been colored to show per-vertex quantities.

If you really want to fade in a surface, I recommend fading it in as a single-color surface and then showing Coulombic coloring after that.  You could actually have two separate surfaces and fade in the non-Coulombic-colored one and then do a rapid switcheroo of hiding that one and showing the already-made Coulombic one.

I hope this helps,
Elaine C. Meng, Ph.D.                       
UCSF Chimera(X) team
Department of Pharmaceutical Chemistry
University of California, San Francisco

More information about the Chimera-users mailing list