[Chimera-users] Question about disulfide bonds and energy minimization

Eric Pettersen pett at cgl.ucsf.edu
Fri Jul 20 13:10:16 PDT 2018

When Chimera is setting up the MMTK version of the molecular system so that MMTK can run the minimization, it skips bonds that it doesn’t think are actual covalent bonds.  Bonds whose display value is 0 (i.e. never show the bond) are skipped as those are typically the ones connecting across a missing-structure gap (actually depicted by pseudobonds in Chimera).  Therefore, to get the MMTK minimization to include your long disulfides which are being treated as missing structure you need to run this command:

	setattr b display 2

before running any minimization of the system (i.e. before Chimera constructs the MMTK system).  Then the minimization will correct the disulfide lengths.


	Eric Pettersen
	UCSF Computer Graphics Lab

> On Jul 20, 2018, at 9:50 AM, Elaine Meng <meng at cgl.ucsf.edu> wrote:
> Hi Steve,
> There is no “set length” command, so that would explain why it doesn’t work!  There is a graphical interface, menu: Tools… Structure Editing…. Build Structure, and then in that dialog, change from the “Start Structure” panel to “Adjust Bonds”.  Then you have to select the bond(s) with Ctrl-click in the main window and in the dialog, use the slider or type in a value.
> Some of your disulfides are initially shown as dashed lines because Chimera recognizes them as too long to be a real bond and shows a “missing segment” pseudobond.  It won’t work to select these dashed lines and try to use Adjust Bonds.  Instead you can get rid of the dashed lines (menu: Tools… General Controls… Pseudobond Panel, choose “missing segments” on the left and “close” on the right, NOT the Close button on the bottom which would close the dialog).  Then force the long covalent bonds to be shown with command:
> setattr b display 2
> Then you can select the bond and use Adjust Bonds as described above.  However, that will just force the bond to shorten without reasonable change propagating through the structure, so you would still need some kind of relaxation (dynamics/minimization).
> Maybe look into whether you can do your modeling step in a way that preserves the disulfide bonds (if they were in the template too), so that you don’t have to try to accommodate them afterwards.
> When I minimize your model structure, I agree it seems like a very small amount of movement.  However, I see in the Log that some things are changing slightly and energy values are changing.  It may have something to do with the cysteines.  I’ll look into whether it is necessary to change them to CYX or something like that (they may not be “feeling” the strained S-S bonds if they “think” they are just regular CYS residues).
> I hope this helps,
> Elaine
> -----
> Elaine C. Meng, Ph.D.                       
> UCSF Chimera(X) team
> Department of Pharmaceutical Chemistry
> University of California, San Francisco
>> On Jul 20, 2018, at 1:41 AM, Steven Douglas Aird <steven.aird at oist.jp> wrote:
>> Dear Elaine,
>> For the first time in about three years, I need to do a little more modeling.   We sequenced an NADase and I used Galaxy to create a model using a known CD38 structure as a template (attached).  Chimera displayed everything, but the disulfide bonds, of course.  So I entered the specifications for those manually into the PDB file (attached).  Two of the disulfides displayed properly, but four appear as thin dashed lines.  At least one, at the C-terminus is clearly way too long.  
>> I tried to do an energy minimization, but while Chimera executed the steps, nothing in the structure moved.  It used to be that one could watch the structure flex as it assumed the most energetically favorable conformation, but not this time, yet some of the disulfide bond lengths are clearly wrong.
>> I also tried to use the set length command, in the forms:  set length 2.05 / Set Length [2.05]  but Chimera does not like either of these commands.  If the manual included examples of the command format for each command, that would be really useful, because it is not clear where the syntax problem lies.
>> As always, thanks for your help!
>> Sincerely yours,
>> Steve 
>> Steven D. Aird
>> Technical Editor
>> Faculty Affairs Office
>> Okinawa Institute of Science and Technology Graduate University
>> 1919-1 Tancha, Onna-son
>> Kunigami-gun, Okinawa-ken
>> Japan  904-0495
>> Phone:  098-982-3584
>> Cell:  080-4154-9504
>> Email:  steven.aird at oist.jp
>> <M suri M1.py><model_1.pdb>_______________________________________________
>> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
>> Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
> Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20180720/5f195a65/attachment.html>

More information about the Chimera-users mailing list