[Chimera-users] SwissSidechain plugin for Chimera

Elaine Meng meng at cgl.ucsf.edu
Tue Apr 17 11:26:22 PDT 2018

Hi Madeline,
I tried the whole installation process myself this morning to verify that it worked.  One confusing thing is that you should not add the “SwissSidechain” directory itself, but the directory above it.  E.g. I put it inside ~/Desktop/plugins/ and added the plugins directory to my locations and everything worked : it was in the menu and the command worked.  I did not change the name of the SwissSidechain folder produced by unzipping the downloaded file from the SwissSidechain website, I just moved it inside my plugins folder, Other than that, I have no idea what to tell you.
I hope this helps,

> On Apr 17, 2018, at 11:18 AM, Madeline Rollins <madelinerollins2015 at u.northwestern.edu> wrote:
> Thank you, I hadn't even noticed that. But I have tried swapnaa as well, only with a different error message reading "Unrecognized command: 'swapnaa'." I think my main problem is that the plugin hasn't installed, given that swapnaa doesn't work at the command line and there is no option for SwissSidechain in the Tools > Structure Editing drop down menu. I'm not sure where to direct this question, but I was wondering if this problem is common or if there were any known solutions (I couldn't find any in the archived answers).
> Madeline
> On Tue, Apr 17, 2018 at 12:40 PM, Elaine Meng <meng at cgl.ucsf.edu> wrote:
> Hi Madeline,
> One tiny “a” makes a big difference!
> The command should be “swapnaa,”  as described on the SwissSidechain website:
> <https://swisssidechain.ch/visualization/chimera.php>
> e.g.
> swapnaa SEP #0:95.A
> The “swapna” command is for nucleic acids. Easy mistake to make, of course, with the commands being so similar.
> I hope this helps,
> Elaine
> -----
> Elaine C. Meng, Ph.D.                       
> UCSF Chimera(X) team
> Department of Pharmaceutical Chemistry
> University of California, San Francisco
> > On Apr 17, 2018, at 9:45 AM, Madeline Rollins <madelinerollins2015 at u.northwestern.edu> wrote:
> > 
> > To whom it may concern,
> > I am trying to mutate a residue of my protein of interest to one of the non-natural sidechains (phosphoserine) in the SwissSidechain database. I downloaded the SwissSidechain plugin onto my computer a few months ago and it worked fine, but it recently disappeared and I have been trying to re-download it. I have downloaded the zip file from the SwissSidechain website, extracted all of the files inside (both the dependent and independent Rotamer folders) and have added the directory containing the location in the tools category. However, the SwissSidechain module still doesn't appear under the Tools > Structure Editing menu. When I try to use the command "swapna SEP #0:95.A" (for example), I get an error message that reads "No connectivity template for residue 'SEP'." Do you have any advice on how to solve this issue?
> > Thank you,
> > 
> > Madeline Rollins

More information about the Chimera-users mailing list