[Chimera-users] MultiFit is not working

Elaine Meng meng at cgl.ucsf.edu
Wed Nov 2 11:38:22 PDT 2016

Hi Julia,
I can only suggest reading the error message from Chimera (which you included below) and following its suggestions.  See below, starting “Typically…”  Basically it says the web service is down but should be up later.  

I tried the MultiFit web service and it is running now, so maybe it would work if you just tried again.

Alternatively, instead of MultiFit, you could try the “fitmap” command, which can fit multiple structures sequentially or do symmetric fitting without using a web service.

I hope this helps,
Elaine C. Meng, Ph.D. 
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

> On Nov 2, 2016, at 5:23 AM, Smirnova, Julia <julia.smirnova at charite.de> wrote:
> Dear  Chimera-team,
> I was trying to use a MultiFit service of Chimera (to fit two models into my cryo density map), and it gives me the following error:
> Wrote /tmp/tmp_rSyaW/INSRT_model2.pdb
> Wrote /tmp/tmp_rSyaW/1x1n.pdb
> Traceback from web service request (connection setup):
> Traceback (most recent call last):
>   File "/opt/UCSF/Chimera64-1.11.2rc/share/WebServices/opal_client.py", line 11, in __init__
>     self._setup(serviceName, opalURL, sessionData)
>   File "/opt/UCSF/Chimera64-1.11.2rc/share/WebServices/opal_client.py", line 52, in _setup
>     md = self.sudsClient.service.getAppMetadata()
>   File "/opt/UCSF/Chimera64-1.11.2rc/lib/python2.7/site-packages/suds_jurko-0.6-py2.7.egg/suds/client.py", line 280, in __getattr__
>     port = self.__find(0)
>   File "/opt/UCSF/Chimera64-1.11.2rc/lib/python2.7/site-packages/suds_jurko-0.6-py2.7.egg/suds/client.py", line 315, in __find
>     raise Exception, 'No services defined'
> Exception: No services defined
> Typically, if you get a TypeError, it's a problem on the remote server
> and it should be fixed shortly.  If you get a different error or
> get TypeError consistently for more than a day, please report the
> problem using the Report a Bug... entry in the Help menu.  Please
> include the traceback printed above as part of the problem description.
> Traceback from web application request:
> Traceback (most recent call last):
>   File "/opt/UCSF/Chimera64-1.11.2rc/share/WebServices/appWebService.py", line 48, in _initApp
>     self.backend = Backend(service, url)
>   File "/opt/UCSF/Chimera64-1.11.2rc/share/WebServices/opal_client.py", line 21, in __init__
>     raise NonChimeraError("Web service appears "
> NonChimeraError: Web service appears to be down.  See Reply Log for more details.
> Service 'opal:MultiFitWebService' is unavailable.  See Reply Log for more details.
> Could you please give me a clue what might be a problem.
> I do have an internet connection (checked by 'Fletch by ID... ' function)
> Thank you for your support,
> Julia

More information about the Chimera-users mailing list