[Chimera-users] saving pdb with transformed coordinates

Eric Pettersen pett at cgl.ucsf.edu
Thu Dec 1 13:12:48 PST 2016

Elaine’s response caused me to realize the other problem with your script — you are going to need to add “; wait” to the end of any rock/roll/turn command you use.  Otherwise the script will keep going without any frames being drawn, which also means that no motion from the rock/roll/turn will have occurred, and therefore the coordinates will be unchanged when the script reaches your “write” command.


	Eric Pettersen
	UCSF Computer Graphics Lab

> On Dec 1, 2016, at 1:04 PM, Elaine Meng <meng at cgl.ucsf.edu> wrote:
> Hi Michael,
> I was unable to reproduce this problem… I tried “turn y 90”  and then "write #0 ~/Desktop/test.pdb” and it did write the transformed coordinates, and should behave the same way if run via python with rc.  I guess you can doublecheck  by actually typing commands (let us know if still problematic) and then make sure the same commands are used in your script.
> A separate issue:  I see your script uses “rock” whereas you probably wanted “roll” or “turn” … note that “rock y 10 1” will not rotate 10 degrees, but perform 1 frame of a rocking oscillation that would have covered a 10 X 20 = 200-degree angle had it been allowed to perform a full cycle of 136 frames.  Instead use “turn y 10”  or “roll y 10 1” if you want to rotate 10 degrees around Y.
> <http://www.rbvi.ucsf.edu/chimera/docs/UsersGuide/midas/rock.html>
> <http://www.rbvi.ucsf.edu/chimera/docs/UsersGuide/midas/turn.html>
> I hope this helps,
> Elaine
> -----
> Elaine C. Meng, Ph.D.                       
> UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
> Department of Pharmaceutical Chemistry
> University of California, San Francisco
> On Dec 1, 2016, at 10:23 AM, Michael Elbaum <michael.elbaum at weizmann.ac.il> wrote:
>> Dear Chimera people,
>> I'm trying to create a series of pdb files showing a single structure rotated around a given axis. Using the GUI I can turn the molecule and save the pdb after unclicking the "Use untransformed coordinates" box. However, when I run a script using the write command I don't know how to invoke this option. The docs on the "relative" option suggest that the default is to write transformed coordinates.
>> I've tried the following:
>> for i in xrange(0,90,10):
>>    rc("rock " + "y " + str(i) + " 1")
>>    fn = basefn + str(i) + '.pdb'
>>    rc("write format pdb 0 " + fn)
>> and the files end up identical although the rotation around y does appear on the screen. I had the problem in version 1.10.2 and it remains after upgrading to 1.11.
>> thanks for your help,
>> Michael
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
> Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20161201/8f98f78a/attachment.html>

More information about the Chimera-users mailing list