[Chimera-users] Matchmaker 'restrict to selection' not working as expected.

Oliver Clarke olibclarke at gmail.com
Sat Nov 21 17:15:02 PST 2015

Hi all,

When using Matchmaker, the ‘Further restrict to matching selection’ option does not seem to improve the speed of alignment as much as expected under certain circumstances (when the selection is a subset of a larger chain, as opposed to being an individual chain in a multi chain structure). 

It seems to still restrict the selection correctly for the final alignment (it is still only aligned on the selected domain), but the “test match” step seems to be conducted on the entire chain, rather than the selection - this makes a big difference to speed for large proteins.

For example - I tried aligning two conformations of a protein complex consisting of one chain A ~100 residues, and chain B ~5000 residues.

If I select chain A of both structures, and then select ‘Further restrict to matching selection’ for both the reference and the structure to match, the alignment is almost instantaneous - less than 2s.

If I perform the same operation, but this time selecting the first 100 residues of chain B in each structure, the alignment takes 3min20s, regardless of whether I leave automatic chain pairing on or select the specific chains to use for alignment manually. It takes only marginally longer - 5 min - if I select the entirety of chain B, a selection that is 50X the size.

Incidentally I still get the “test match” message in the status bar even when the selection only contains one chain from each structure, or when I manually select (using the chain pairing options) which chains to align - maybe Chimera is still running test match on the whole chain when it should only do so on the selection (or not at all if the selection only includes one possible match).

This seems like a bug? Or am I missing something?


More information about the Chimera-users mailing list