[Chimera-users] 2dlab problem

Elaine Meng meng at cgl.ucsf.edu
Wed Dec 23 09:48:38 PST 2015

Hi John,
My guess is that you are using special-character start/end quotation marks, not just the simple quotation marks directly from the keyboard.  You can see the difference in that the special characters curl in opposite directions whereas the simple ones directly from the keyboard are more straight, and the start and end marks look the same as each other.

For example, if I just paste your example command into the command line, I get the same error as you reported.  Then if I edit the command line to replace the special-character quotation marks with ones directly from the keyboard (single or double, either will work), the command works to create the label.

I won’t enter the command with the simple quotation marks here because I think my Mail app will change them into the fancy special-character ones!

I hope this helps,
Elaine C. Meng, Ph.D. 
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

> On Dec 22, 2015, at 4:34 PM, jrb53 <jrb53 at uw.edu> wrote:
> Hello all,
> I am making a movie in Chimera and labelling the various proteins as they appear. For some reason I am having trouble with 2dlab
> If I write
> 2dlab create kvlab4 text “Voltage-gated potassium channel” size 48 style bold color blue xpos .04 ypos .9
> I get the error
> Keyword 'potassium' doesn't match any known keywords
> Its like it doesn’t get that the quotes are even there and it sees the label as multiple command line arguments. I get the same error with single quotes. If I use one word labels, it works fine.
> Any idea? Or am I missing something simple?
> John

More information about the Chimera-users mailing list