[Chimera-users] superimposing two structures based on a specific selection

Tom Goddard goddard at sonic.net
Mon Feb 10 10:28:57 PST 2014

Hi David,

  I tried exactly your command in Chimera 1.8 with two randomly chosen model (3pfj, 2gbp) and match worked as expected (after removing the space after "#1:" which gives an error).  So to know why your case does not work we'd need the actual PDB models you are using.  But without those here is my suspicion.  The match doesn't move the first model because it is already aligned.  You could test this by moving one model relative to the other, then try the command again (use the Active buttons in Model Panel to freeze one model, then move the other with the mouse).

  Also the specifier "#0:5-15 at CA,20-30 at CA" has the wrong syntax.  It should be #0:5-15 at CA:20-30 at CA" (with the comma replaced by a colon).  The first specifier will only select the 11 CA atoms 5-15 because with the comma it says take atoms named CA and atoms named "20-30" and atoms named CA.  There are no atoms named "20-30".  This explains why your rmsd values don't depend on the 20-30 or 21-31 or 20-35.

  Here is some documentation on atom specifiers


Note that the 7th example is the same kind of specifier you were attempt with two residue ranges.


On Feb 10, 2014, at 3:08 AM, David Martin <d.m.a.martin at dundee.ac.uk> wrote:

> Chimera 1.8 on Windows
> I have been trying to align (superimpose) models based on a specific conserved region. Unfortunately Chimera doesn’t seem to do what the documentation claims it does.
> I run (example):
> match #0:5-15 at CA,20-30 at CA #1: 5-15 at CA,20-30 at CA
> and get an RMSD calculation (more on this below), but no movement of the model occurs. I specify ‘move true show true’ as options. Still no movement but I have a transformation matrix. Unfortunately this is not in a form that can be understood by Transform Coordinates.
> How do I persuade my structures to superimpose on the specific atoms?
> The RMSD calculation appears to be broken.  If I take the command
> rmsd #0:5-15 at CA,20-30 at CA #1: 5-15 at CA,20-30 at CA
> then I will get a number
> If I then run
> rmsd #0:5-15 at CA,20-30 at CA #1: 5-15 at CA,21-31 at CA
> I get exactly the same number. In fact, if I specify atom sets of different sizes (as long as it is not the first block) then I continue to get exactly the same number
> rmsd #0:5-15 at CA,20-30 at CA #1: 5-15 at CA,20-35 at CA
> This should fail but doesn’t
> Have I completely misunderstood what Chimera should be doing here?
> ..d
> The University of Dundee is a registered Scottish Charity, No: SC015096 _______________________________________________
> Chimera-users mailing list
> Chimera-users at cgl.ucsf.edu
> http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20140210/d608a59c/attachment.html>

More information about the Chimera-users mailing list