[Chimera-users] Chimera on a virtualbox

chris.wood at stfc.ac.uk chris.wood at stfc.ac.uk
Tue Feb 5 16:38:18 PST 2013

Hi Greg,

I know that doing anything with graphics within virtual machines is not always a brilliant idea, but I have seen Chimera work in VirtualBox and I wanted to get to the bottom of why mine doesn't...

I've got the latest graphics driver on my host (and I run Chimera successfully on it anyway).  I've run the commands you suggested, with the following output

$ gdb $CHIMERA/bin/python2.7
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /home/ccw/.local/chimera-1.7/bin/python2.7...done.
(gdb) break_exit
Undefined command: "break_exit".  Try "help".
(gdb) run $CHIMERA/share/__main__.py --debug
Starting program: /home/ccw/.local/chimera-1.7/bin/python2.7 $CHIMERA/share/__main__.py --debug
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Traceback (most recent call last):
  File "/home/ccw/.local/chimera-1.7/share/__main__.py", line 69, in <module>
    value = chimeraInit.init(sys.argv)
  File "/home/ccw/.local/chimera-1.7/share/chimeraInit.py", line 594, in init
    import chimera
  File "/home/ccw/.local/chimera-1.7/share/chimera/__init__.py", line 16, in <module>
    from _chimera import BBox, Camera, Color, ColorGroup, DirectionalLight, LODControl, Lens, LensViewer, Light, Material, MaterialColor, Model, NoGuiViewer, OGLFont, OSLAbbreviation, OpenModels, OpenState, PathFinder, PixelMap, Plane, Point, PositionalLight, Selectable, SharedState, SpotLight, Sphere, Texture, TextureColor, TrackChanges, Vector, Viewer, X3DScene, Xform
ImportError: libgfxinfo.so: cannot open shared object file: No such file or directory
[Inferior 1 (process 4025) exited with code 01]
(gdb) bt
No stack.

I guess the lack of libgfxinfo.so is fairly significant, and I assume that the result from bt is all part of the problem?


From: chimera-users-bounces at cgl.ucsf.edu [mailto:chimera-users-bounces at cgl.ucsf.edu] On Behalf Of Greg Couch
Sent: 05 February 2013 23:26
To: Chimera-users at cgl.ucsf.edu
Subject: Re: [Chimera-users] Chimera on a virtualbox

(Forgot to send reply to whole list)
-------- Original Message --------

Re: [Chimera-users] Chimera on a virtualbox


Tue, 05 Feb 2013 13:51:47 -0800


Greg Couch <gregc at cgl.ucsf.edu><mailto:gregc at cgl.ucsf.edu>


chris.wood at stfc.ac.uk<mailto:chris.wood at stfc.ac.uk>

Hi Chris,

So what are you trying to do with Chimera inside a virtual machine?  Presumably, you're not trying to use it graphically because virtualized graphics performance is usually abysmal.  Chimera benefits immensely from direct access to the graphics hardware.  So that leaves using Chimera as a server, and for that the headless version of Chimera is usually better -- the headless version uses a software implementation of OpenGL and thus avoids any driver issues.

That said, this bug is still likely to be related to OpenGL support in VirtualBox.  Make sure the computer that VirtualBox is running on has an up-to-date OpenGL graphics driver.  It doesn't matter what VirtualBox does if the underlying system has a bad graphics driver.

To confirm that the bug is in the graphics driver, get a backtrace of where the error occurs by using gdb as follows in a Terminal window (and assuming there is a symbolic link to the chimera binary on your path):

    % export CHIMERA=`chimera --root`
    % export LD_LIBRARY_PATH=$CHIMERA/lib
    % gdb $CHIMERA/bin/python2.7
    (gdb) break_exit
    (gdb) run $CHIMERA/share/__main__.py --debug
    (gdb) bt

The '%' and '(gdb)' parts are the shell and gdb prompts, respectively.  The output from the bt command will probably be in Chimera's molecular drawing code (as opposed to drawing the UI).  If you need help interpreting the chimera backtrace, you can send it to me.



On 02/05/2013 12:48 PM, chris.wood at stfc.ac.uk<mailto:chris.wood at stfc.ac.uk> wrote:
Hello all,

I'm trying to run Chimera on VirtualBox. The installation completes fine, but when I try and run the program (cd to the bin directory and run ./chimera) I see

X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request:  72 (X_PutImage)
Resource id in failed request:  0x480006a
Serial number of failed request:  1382
Current serial number in output stream:  1388

I've tried enabling / disabling hardware virtualization & 3D acceleration, but to no avail. Although people do seem to have problems with chimera on a virtualbox, it normally seems to be a problem with OpenGL, which this doesn't seem to be.

Has anyone seen this error before? Is there anything else I'm missing? I can't even work out if it's a hardware, VirtualBox, or OS problem...

VirtualBox 4.2.4
Guest additions 4.2.4
Guest OS: Ubuntu 12.04
Host OS: Windows 7 professional

Thanks in advance!
Dr Chris Wood
STFC Rutherford Appleton Laboratory
OX11 0QX

chris.wood at stfc.ac.uk<mailto:chris.wood at stfc.ac.uk>

Tel: +44(0)1235 567864
Tel: +44(0)7909 586624
Fax: +44(0)1235 567801

Scanned by iCritical.

Scanned by iCritical.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20130206/8535fe06/attachment.html>

More information about the Chimera-users mailing list