[Chimera-users] Set and rna commands

Elaine Meng meng at cgl.ucsf.edu
Mon Dec 30 15:51:50 PST 2013

Hello Janusz Grabowski,
It is impossible to tell what was wrong with your commands given so little information.  You would need to say exactly what commands you tried (including all keywords).  The commands I tried worked.  Notice that several of the "rna" sub-commands and examples in the manual page specify data that must already exist (sequence text file in FASTA format, markers in Chimera tracing out the desired 3D path, etc.), or require the results from some earlier modeling step (minimizing requires you to have already built something).  So of course if you copy the example exactly but you don't have the sequence file or the markers or anything to minimize, it wouldn't work.

Although it is possible to make short sequences with "rna" without using pre-existing data files, for example: 

rna model AACCAAAAAAGGUU pairs 1,14,4

…the "rna" command is mainly for making *approximate* models, especially for very long sequences.  How to use the various options is given along with descriptions of the algorithms in the manual page:

If you want to make a more precise model, a different approach may be preferred:

(a) if you want to make a regular helical conformation and the sequence is not too long to type, you may prefer to use the Build Structure graphical interface (in menu under Tools… Structure Editing).  The "Start Structure" section of Build Structure has a "helical DNA/RNA" option.

(b) if you want to build a larger RNA with complicated secondary structure, there is a nice plugin "Assemble2" available separately from Chimera:

The set command is pretty simple.  It is described here (or use command "help set" to see the same thing):

set shadows
~set shadows
set bgColor gray

Elaine C. Meng, Ph.D. 
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

On Dec 26, 2013, at 7:06 AM, "pythonchemia Gazeta.pl" <pythonchemia at gazeta.pl> wrote:

> Hello ! 
> I have winXP and Chimera version 1.8. I wanted to use the commands rna and set.
> Unfortunately, they do not work. Why? What is it?
> I tried to repeat the example of the User's Guide for rna command and failed. Please help me or give me examples on the set command and rna
> Sincerely, Janusz Grabowski

More information about the Chimera-users mailing list