[Chimera-users] saving coords from script

Tetsuro Fujisawa fujisawa at gifu-u.ac.jp
Fri Dec 20 01:58:11 PST 2013

The following bug report has been submitted:
Platform:        windows
Chimera Version: 1.8.1

I found some strange behavior in saving pdb file by script file.
I tried to modify the orientation of pdb file ‘tst.pdb’ (#1) in reference to axis coordinate (#0), then save the atomic coordinates in pdb file.
When I typed in the commands through either command line window or IDLE, transformed coordinates were saved. It worked fine. However, the exact identical commands (inside the brancket) or lines (rc(’..’)) were run by script file shown in below, the untransformed coordinates were saved.  This is also the case for “Midas.write method”.  
I wondered this might be a bug.


from chimera import runCommand as rc

rc('open axis.bild')
rc('open tst.pdb')
rc('rock y 60 1 center #1 coord #0 models #1')
# orientation of tst.pdb was modified
rc('write relative #0 #1 tstA.pdb')
# write current coordinates to tstA.pdb
rc('open tstA.pdb')
# opened tstA has original untransformed orientation

More information about the Chimera-users mailing list