[Chimera-users] [Dock-fans] Help with antechamber

Scott Brozell sbrozell at rci.rutgers.edu
Wed Feb 29 19:30:06 PST 2012


Here's another similar ligand prep script:
While it is a good pedagogical exercise to prep once manually,
scripting is the only practical approach for lots of ligands.

As far as running antechamber, be careful and be specific about which
one you run:  
If you are manually running Dock's antechamber then define DOCK_HOME.
Do not define AMBERHOME.

If you are manually running Chimera's antechamber then DOCK_HOME
is irrelevant but AMBERHOME may be relevant.
( I have not manually run Chimera's antechamber, so my advice may be wrong. )

Also note that Dock's antechamber is circa 2006 with some key subsequent
bugfixes.  Chimera's antechamber is much more recent.
Dock's antechamber uses mopac for qm;
Chimera's antechamber uses sqm for qm;
I have found mopac to be more robust than sqm.
Your mileage may vary.


On Wed, Feb 29, 2012 at 04:08:22PM -0800, Eric Pettersen wrote:
> This previous posting to the dock-fans list seems to be more directly  
> pertinent:
> http://mailman.docking.org/pipermail/dock-fans/2007-May/001043.html
> On Feb 29, 2012, at 2:47 PM, Trent E. Balius wrote:
> >I am cc'ing this to the chimera list.
> >
> >I think that you should write a python script to run DOCK prep on  
> >the command line.  See the following:
> >
> >http://www.cgl.ucsf.edu/pipermail/chimera-dev/2011/000784.html
> >
> >For other example scripts see the following:
> >
> >http://www.cgl.ucsf.edu/pipermail/chimera-users/2009-February/003539.html
> >
> >You should not have to specify the AMBERHOME path.  This is done  
> >internally to chimera.
> >
> >as an aside, It is unnecessary to run antichamber with sudo.
> >
> >-----Original Message-----
> >From: Brad Ridder <clustro at gmail.com>
> >To: dock-fans <dock-fans at docking.org>
> >
> >My name is Brad; I am a grad student in the dept. of chemical  
> >engineering at Purdue University.
> >
> >We are experimenting with DOCK for various drug discovery work. At  
> >the moment, I am trying to do execute all of the "dock prep"  
> >commands through the Terminal, since it is not practical to do large  
> >volumes of Dock Prep by hand through the CHIMERA GUI.
> >
> >Corresponding to what is in the DOCK tutorial, I am on "Receptor and  
> >Ligand Preparation." I got reduce to work, in order to add hydrogens.
> >
> >Now, I am trying to get antechamber to work, in order to add the  
> >charges, but it is not working. Here is the command I am running:
> >
> >sudo ./antechamber -i $DESKTOP/3GLR.pdb -fi pdb -o $DESKTOP/ 
> >3GLRcharged.mol2 -fo mol2
> >
> >Which returns the error:
> >
> >Warning: $AMBERHOME and $DOCK_HOME enviornment strings are not set,  
> >use "mopac.sh" in the work directory
> >
> >Cannot open CONNECT.TPL , exit
> >The atom number exceeds the MAXATOM, reallocate memory
> >
> >I looked around in the dock6 directory, and found a folder called  
> >"parameters/antechamber", which contains CONNECT.TPL. I figured this  
> >is what should be the $AMBERHOME directory.
> >For DOCK_HOME, I figured it should be the dock6 folder.
> >
> >Here is what I have in my .bash_profile file in my home folder.
> >
> >export AMBERHOME='/home/.../DOCK6.5/dock6/parameters/antechamber'
> >export DOCK_HOME='/home/.../DOCK6.5/dock6'
> >
> >I also tried using the "amber11" folder that comes with CHIMERA as  
> >AMBERHOME, but to no effect.
> >
> >I don't actually have AMBER installed on my computer, but since  
> >CHIMERA can add charges without actually requiring the purchase of  
> >AMBER, I do not think that is the problem.
> >
> >I did not know what to do with "mopac.sh." I ran the script, but it  
> >says it needs input files.
> >
> >What am I doing wrong that is preventing antechamber from executing  
> >correctly?

More information about the Chimera-users mailing list