[Chimera-users] Failed surface calculation

Elaine Meng meng at cgl.ucsf.edu
Fri Jan 22 16:32:22 PST 2010

Dear Ibrahim,
This is common and represents a numerical failure of the MSMS code  
included with Chimera for calculating molecular surfaces.

The first thing to do is make sure you have a fairly recent version  
of Chimera, say 1.4 from Dec 2009 or newer.  Although we have not  
eliminated the failures, we have made some improvements that reduce  
their frequency.

Sometimes when there is an error, it can still fall back to a "single  
component" calculation.  The problem may be in some inside bubble,  
whereas the "single component" is the main outer surface.  If that's  
what happened, but it still looks like you got the surface you want,  
you can ignore the message.

If you didn't get any surface, however, there are several things to  
try, as mentioned in several previous posts (links below).   
Unfortunately none is a magic bullet that works in all situations.


Because of the MSMS problems, we have been working for many months on  
code to replace it, but it is not yet available.

I hope this helps,
Elaine C. Meng, Ph.D.
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

On Jan 22, 2010, at 4:10 PM, Ibrahim Moustafa wrote:
> Dear Chimera,
>  I’m trying to calculate the surface for a protein but I get an error
> ”Surface calculation failed, mscalc returned code 5”.
> I tried to change the probe size from 1.4 to 1.5 or 1.7 but still  
> getting
> the same error. I know there is some issue with
> The code that calculates the surface (if I’m not wrong) but I  
> wonder if
> there is a way to get around this. For some smaller pdb files I  
> don’t have
> this problem.
> I’m not sure if the size of the protein is a factor here. The  
> protein having
> the problem is a single chain protein with 880 amino acids.
> Any advice?
>   Thanks for help.
>  Ibrahim

More information about the Chimera-users mailing list