[Chimera-users] mouse selection not working

Greg Couch gregc at cgl.ucsf.edu
Mon Oct 5 11:01:09 PDT 2009

The bug is not in chimera, rather it is somewhere in Ubuntu's OpenGL 
support.  Probably in the libgl1-mesa-glx or libgl1-mesa-dri packages or 
possibily a different mesa-based package.  FYI, if you were to downgrade 
mesa, you will probably need to downgrade the X.Org server to match.

You might be to find a workaround by editing your /etc/X11/xorg.conf file 
and changing the settings in the Device Section.  See what Driver you have 
(I'd like to know which you have too), and read the manual page about that 
driver to see what your options are.  It should also be possible to switch 
to a simplier driver, like vesa or fbdev, but I have never tried that.

 	Good luck,


On Mon, 5 Oct 2009, lorenzo wrote:

> Thank you very much Creg for the prompt answer.
> Actually, since now, chimera has worked just wonderfully on every Ubuntu
> release I happened to deal with.
> I made a diff (linux command diff) between my /usr/local/chimera and
> that of the chimera I installed this summer on my wife netbook (ubuntu
> 8.04) and the only differences are in /usr/local/chimera/lib). Me and my
> wife sport symbolic links to different sets of libraries.
> My wife for example has:
> libGLw.so
> libqhull.so.5
> libGLU.so
> libftgl.so
> libexpat.so.1
> libpng12.so.0
> libswish-e.so.2
> libGLU.so.1
> libhdf5.so.0
> libqhull.so
> libcrypto.so
> libpng12.so
> libfreetype.so.6
> libGLw.so.1
> libhdf5.so
> Which of those libraries is responsible of the mouse selection tool?
> My plan is to install a down-graded version of the guilty library for
> chimera to use it.
> If the answer is "more than one library is involved" which do you feel
> are the best guesses to start with.
> Thanks again
> Lorenzo
> -----Original Message-----
> From: Greg Couch <gregc at cgl.ucsf.edu>
> To: lorenzo <bongini at fi.infn.it>
> Cc: chimera-users at cgl.ucsf.edu
> Subject: Re: [Chimera-users] mouse selection not working
> Date: Sun, 4 Oct 2009 00:01:48 -0700
> On Thu, 1 Oct 2009, lorenzo wrote:
>> Hi everybody,
>> I just installed chimera-1.3-linux.exe on an atom netbook. The OS is
>> ubuntu 9.04. My problem is that the mouse selection tool does not work.
>> To complete the scenario I add a few details
>> 1) I don't have the green outline and setting Fill mode for selection
>> highlighting in Preferences does not work around the problem (probably
>> just a screen setting problem).
>> 2) Other forms of selections work. For example by Select -> Chemistry ->
>> Element -> H and then by Actions -> Atoms/Bonds -> Delete I can delete
>> hydrogens.
>> 3) I cannot delete anything that I select by ctrl + mouse left button.
>> 4) libgl1-mesa-glx and libgl1-mesa-dri are installed.
>> Thanks for your attention
>>      Lorenzo Bongini
> I'm pleasantly surprised to hear that chimera 1.3 works at all on ubuntu
> 9.04.  Many of the recent Linux distributions have altered their setup
> enough to break chimera, so that is very good news.  For those other linux
> distributions, the chimera daily build will be better.
> But, the fact that the mouse selection tool does not work strongly
> suggests that there is a bug in the one of the mesa (OpenGL) packages.
> And since you're using ubuntu, you should file a bug report with them, so
> it will get fixed and then, at some later date, the fix will show up in an
> ubuntu update (e.g., the upcoming ubuntu 9.10).  Feel free to list me as
> a technical contact.
> As an aside, mesa is undergoing huge internal changes right now, partially
> to improve the performance on low-end systems, so recent versions of Linux
> are especially prone to OpenGL/mesa bugs.  If you have an ATI or NVidia
> chipset in your computer, you will probably be better off installing the
> closed-source driver from the respective vendor.
>      -- Greg

More information about the Chimera-users mailing list