[Chimera-users] povray error using surfrepr mesh

Greg Couch gregc at cgl.ucsf.edu
Wed May 20 13:45:41 PDT 2009

On Tue, 19 May 2009, Sebastian Kruggel wrote:

> Dear Chimera-users and team,
> I tried to generate a POV-Ray image making use of mesh style surface by
>> surfrepr mesh
> When I go to 'save image' with activated POV-Ray option, I get the attached 
> error message. I tried several versions ('stable' and daily build, linux and 
> windows) and different molecules but it doesn't work out. Isn't it possible 
> to get raytraced mesh-surface pictures in chimera or do I miss anything?
> Thanks in advance and best regards
> Sebastian Kruggel

You found a bug in chimera's POV-ray output.  I created a ticket for you, 
so you'll be notified when it is fixed.

Currently, the only workaround is to set the POV-ray options to keep the 
input files and save an image with POV-ray, so when it fails, you have the 
image.ini and image.pov files.  Then you'll need to edit the image.pov 
file and change the refererences to the unknown texture to a known one 
(see the #declare's at the top of the image.pov file).  And, finally, run 
POV-ray by hand:

 	CHIMERA/bin/povray +Iimage.pov +Oimage.png image.ini

FYI, with this simple workaround, the mesh is all one color.

 	- Greg

More information about the Chimera-users mailing list