[Chimera-users] CHARMM PBEQ calculations

Fabian Glaser fglaser at technion.ac.il
Wed Aug 20 11:01:33 PDT 2008

Hi Tom,

First, thanks a lot to you, to Sunhwan, Elaine and to you for helping so 
much. Indeed the addition you mentioned solved the problem, although 
additionally I installed delphi which works very smoothly with chimera, 
but it's good in any case to have a way to work with charmm output and 
to have both methods available. 

Secondly, I have a question regarding the surface potential itself: Once 
the delphi run ends and I get the surface colour coded by 
electrostatics, (or conservation, etc.) it would be very useful to be 
able to know which residues is found in any specific negative or 
positive potential region (or conserved). But when the surface is shown, 
the cursor doesn't show the residue information as when the cpk 
representation is on (like #0 THR 684.A), and therefore is not easy to 
quickly find information about the residues of interest.

Is there any way to overcome this limitation? It will be really useful.

Best regards and have a great day,


Tom Goddard said the following on 20/08/08 19:49:
> Hi Fabian,
>  The OpenDX file you sent has a small but important error.  It is 
> missing the words "data follows" at the end of the header line that 
> says "object 3 class array..." so Chimera never reads the data.  The 
> misleading error message comes about because the last line of the file 
> is blank and Chimera still thinks it is reading the header.  The 
> header line
> object 3 class array type double rank 0 items 378885
> has to be
> object 3 class array type double rank 0 items 378885 data follows
> Hopefully Sunhwan can update the phi2dx.py script to include the very 
> important "data follows".  The OpenDX format is described in Appendix 
> B of the OpenDX User's Guide:
>    http://opendx.npaci.edu/docs/pdf/userguide.pdf
>  Tom
> Fabian Glaser wrote:
>> Dear Elaine,
>> I am afraid it's still giving the same error when I try to open the 
>> dx file, even when the first line is removed or # starts it. Here is 
>> the message:
>> Opening /media/data/WORKSPACE/PROJECTS/DanCassel/COP/step2_pbeq.dx
>> Error reading file step2_pbeq.dx, format apbs
>> Incorrect format: blank header line.  Comments must begin with # 
>> character.
>> And the dx file is attached, probably I am doing something wrong....
>> THanks a lot,
>> Fabian
>> Elaine Meng said the following on 19/08/08 19:19:
>>> Hi Fabian,
>>> Well, the error message says the format is wrong.  Based on the 
>>> message, you could try removing the blank line at the top of the 
>>> file or adding # in front of it.
>>> If that still doesn't work you could send me the file to look at, 
>>> but it is probably just a simple fix such as the above.
>>> Elaine
>>> -----
>>> Elaine C. Meng, Ph.D.                          meng at cgl.ucsf.edu
>>> UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
>>> Department of Pharmaceutical Chemistry
>>> University of California, San Francisco
>>>                      http://www.cgl.ucsf.edu/home/meng/index.html
>>> On Aug 19, 2008, at 7:03 AM, Fabian Glaser wrote:
>>>> Dear Sunhwan
>>>> Thanks a lot for your kind answer and for the script. The script 
>>>> run fine, but when I try to upload it to chimera I get an error:
>>>> Opening 
>>>> /media/data/WORKSPACE/PROJECTS/HaimManor/EladEliahoo/MODELS/POMBE/CHARMM-PBEQ/charmm-gui/step2_pbeq.dx 
>>>> Error reading file step2_pbeq.dx, format apbs
>>>> Incorrect format: blank header line.  Comments must begin with # 
>>>> character.
>>>> Done opening 
>>>> /media/data/WORKSPACE/PROJECTS/HaimManor/EladEliahoo/MODELS/POMBE/CHARMM-PBEQ/charmm-gui/step2_pbeq.dx 
>>>> Which maybe perfectly chimera problem, so I am CCing this email 
>>>> also to Elaine Meng from the CHIMERA team.
>>>> Any help will be very appreciated,
>>>> Thanks a lot,
>>>> FAbian
>>>> Sunhwan Jo said the following on 19/08/08 15:25:
>>>>> Dear Dr. Glaser,
>>>>> I'm afraid CHIMERA is not able to read CHARMM phi80 format. But 
>>>>> simple
>>>>> search guided me that CHIMERA can to read dx format file, which I 
>>>>> have a
>>>>> converting script. So, please find the script in the attached 
>>>>> file. We've been
>>>>> using this script to read our potential data in Pymol, so I 
>>>>> believe this should
>>>>> be working fine with CHIMERA as well.
>>>>> usage:
>>>>> python phi2dx.py step2_pbeq.phi80 > step2_pbeq.dx
>>>>> Please feel free to contact me, if you have a further problem.
>>>>> Thanks,
>>>>> Sunhwan
>>>>> On Tue, Aug 19, 2008 at 4:53 AM, Fabian Glaser 
>>>>> <fglaser at technion.ac.il> wrote:
>>>>>> Dearl CHARMM team,
>>>>>> have been trying to upload the electrostatic potential calculated 
>>>>>> by CHARMM PBEQ routine to the CHIMERA viewer, since the java 
>>>>>> viewer you use is very good but at least in my machine does not 
>>>>>> work. But despite I have been trying to upload it to chimera 
>>>>>> there seems to be some stubborn problem (or I am doing something 
>>>>>> wrong). What I am trying to do is to color the pdb by the 
>>>>>> potential in chimera so I can freely manipulate it and compare it 
>>>>>> with other calculations.
>>>>>> If you have any suggestion I'll be very grateful,
>>>>>> Best regards,
>>>>>> Fabian Glaser, PhD

Fabian Glaser, PhD

Bioinformatics Knowledge Unit,
The Lorry I. Lokey Interdisciplinary
Center for Life Sciences and Engineering
Technion - Israel Institute of Technology
Haifa 32000, ISRAEL

Web:   http://bku.technion.ac.il
Email: fglaser at tx.technion.ac.il
Tel:   +972-(0)4-8293701
Cel:   +972-(0)54-4772396

More information about the Chimera-users mailing list