[Chimera-users] delphi in chimera

Thomas Goddard goddard at cgl.ucsf.edu
Thu Mar 2 16:51:29 PST 2006

Hi Damien,

  Chimera Delphi Controller tries to execute the command-line program
"delphi" so it must be in your shell executable search path.  On Linux
you need it in the directory containing the delphi executable in the
PATH environment variable.  On the Mac I'm not sure how to set the
search path when you start Chimera by double clicking on it.  You can
still set the shell PATH variable and start Chimera from a terminal

	% path-to-chimera/Chimera.app/Contents/MacOS/chimera

The Chimera User's Guide (under Tools / Delphi Controller) says that
Delphi Controller does not work on Windows.

  Maybe it is easier to just edit the line in Delphi Controller code
that starts delphi.  Just edit line 97 in


changing from

		cmd = "delphi %s > %s" % (self.prmFileName, self.outputFileName)

to for example

		cmd = "/usr/local/bin/delphi %s > %s" % (self.prmFileName, self.outputFileName)

giving an explicit path to the Delphi executable.  On the Mac this file
would be 


Keep the indentation of the Python line the same as this is important.

  All that said, I would suggest just running Delphi yourself then
opening the resulting *.phi file in Chimera.  The Delphi Controller
Chimera tool was written by a summer intern 5 years ago and has not
been worked on much since then.

  The electrostatic potential file produced by MolMol is not in Delphi
format.  It uses a MolMol specific format (described at the end of
this email) that Chimera does not read.  You could hand convert it to
another text file format by changing the header, to say the one used by
APBS (called OpenDX).  But I'd suggest calculating the electrostatic
potential with APBS instead.


Manual page for MolMol potential file format.

     ReadPot - read potentials for surface coloring

     ReadPot fileName

     Read a file with potentials, these are used for
     coloring surfaces. The file must contain values on a
     grid, the format is:

	 x0 xSize xInc
	 y0 ySize yInc
	 z0 zSize zInc
	 val val val ....

     where x0, y0, z0 (float) are the coordinates of the
     grid origin, xSize, ySize and zSize (int) are the
     sizes of the grid in each dimension, and xInc, yInc
     and zInc (float) the spacing between two grid points
     in each dimention. This must be followed by
     xSize * ySize * zSize values (float), where the
     x-coordinate is the one that is running the fastest.

     The potentials will be set for all selected surfaces,
     but the PaintSurface command has to be given to update
     the colors.

     ReadPot /home/joe/struct/my_pot.dat

     CalcPot, AddSurface, SelectPrim, PaintSurface


> From: Damien Devos <damien at salilab.org>
> Date: March 2, 2006 4:04:02 PM PST
> To: "Eric Pettersen (chimera)" <pett at cgl.ucsf.edu>
> Subject: delphi in chimera
> hi Eric,
> i'm trying to use delphi in chimera, but couldn't get the delphi
> controller to help me.
> alternatively, i used molmol to generate the .phi file and tried to  
> open
> it in chimera, but i got this message on the reply log:
> Done opening /viol1/damien/fgf/molmol/1nuna.pdb
> Opening /viol1/damien/fgf/molmol/1nuna.phi
> /viol1/damien/fgf/molmol/1nuna.phi: Record size 539833144 > file size
> 2725332
> Done opening /viol1/damien/fgf/molmol/1nuna.phi
> it seems that my .phi file is too big? does this make sense?
> on the other side, if i could get the delphi controller to work on
> chimera, that would solve all problems. we have delphi installed  
> localy,
> but i don't know where to put the path of it and how so that chimera
> could locate it.
> thanks
> d
> -- 
> Damien Devos
> Andrej Sali Lab
> California Institute for Quantitative Biomedical Research
> University of California at San Francisco
> QB3, Box 2552
> 1700 4th Street, Room 501
> San Francisco, CA 94143-2552 (CA 94158 for courier delivery), USA
> Phone: +1 (415) 514-4258
> Fax: +1 (415) 514-4231
> Email: damien at salilab.org
> URL: http://www.salilab.org

More information about the Chimera-users mailing list