[Chimera-users] WinXP SP1 python error on File -> Open

Pattanayek, Sabuj sabuj.pattanayek at Vanderbilt.Edu
Fri Sep 17 11:04:22 PDT 2004


I'm getting a strange error when I start chimera and do file->open. This is the
reply log:

ValueError: list.index(x): x not in list
(see reply log for Python traceback info)
Traceback (most recent call last):
  File "C:\Program Files\Chimera\share\__main__.py", line 56, in ?
    value = chimeraInit.init(sys.argv)
  File "C:\Program Files\Chimera\share\chimeraInit.py", line 301, in init
  File "C:\Program Files\Chimera\share\chimera\tkgui.py", line 2891, in eventLoop
  File "C:\Program Files\Chimera\bin\lib\lib-tk\Tkinter.py", line 965, in mainloop
  File "C:\Program
Files\Chimera\bin\lib\site-packages\Pmw\Pmw_1_2\lib\PmwBase.py", line 1751, in
    _reporterror(self.func, args)
  File "C:\Program
Files\Chimera\bin\lib\site-packages\Pmw\Pmw_1_2\lib\PmwBase.py", line 1814, in
  File "C:\Program
Files\Chimera\bin\lib\site-packages\Pmw\Pmw_1_2\lib\PmwBase.py", line 1377, in
    _errorReportFile.write(text + '\n')
  File "C:\Program
Files\Chimera\bin\lib\site-packages\Pmw\Pmw_1_2\lib\PmwBase.py", line 1747, in
    return apply(self.func, args)
  File "C:\Program Files\Chimera\share\chimera\tkgui.py", line 272, in _importModel
  File "C:\Program Files\Chimera\share\chimera\tkgui.py", line 178, in __init__
    OpenModeless.__init__(self, **kw)
  File "C:\Program Files\Chimera\share\OpenSave\__init__.py", line 185, in __init__
    ModelessBase.__init__(self, **self.dialogKw)
  File "C:\Program Files\Chimera\share\chimera\baseDialog.py", line 378, in __init__
    BaseDialog.__init__(self, master, *args, **kw)
  File "C:\Program Files\Chimera\share\chimera\baseDialog.py", line 220, in __init__
  File "C:\Program Files\Chimera\share\chimera\tkgui.py", line 181, in fillInUI
    OpenModeless.fillInUI(self, parent)
  File "C:\Program Files\Chimera\share\OpenSave\__init__.py", line 92, in fillInUI
    self.millerBrowser = MillerBrowser(parent, **self.millerKw)
  File "C:\Program Files\Chimera\share\OpenSave\miller.py", line 184, in __init__
    self.makeMainColumn(initialdir, firstTime=1)
  File "C:\Program Files\Chimera\share\OpenSave\miller.py", line 509, in
    titleMode=None, firstTime=firstTime)
  File "C:\Program Files\Chimera\share\OpenSave\miller.py", line 823, in __init__
    index = normItems.index(
ValueError: list.index(x): x not in list

I have also posted the screenshot here

Also if I do "c:\Program Files\Chimera\bin\chimera.exe" file.pdb from the
command line, then do file -> open, it works again. I've tried running it with
and without precompiling modules after installation, but get the same result.

I've downloaded the binary installation several times, done uninstall, then
install, but I'm still getting the same error. I have not been able to re-create
the error on another winxp sp1 machine.

Any help would be appreciated,
Sabuj Pattanayek

More information about the Chimera-users mailing list